summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-genmon-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-genmon-plugin')
-rw-r--r--xfce-extra/xfce4-genmon-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-genmon-plugin/metadata.xml8
-rw-r--r--xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-genmon-plugin/Manifest b/xfce-extra/xfce4-genmon-plugin/Manifest
new file mode 100644
index 000000000000..e97d048b7d2c
--- /dev/null
+++ b/xfce-extra/xfce4-genmon-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-genmon-plugin-3.4.0.tar.bz2 307493 SHA256 b0a5337b49c85623dc89f3c9e47c7374b1d466af2418033d2d6dfc57a9790387 SHA512 9cbe76933414fc539d4a8f803fb31ae31169283e02ded8a4ed13c9c6b2e4af9827313ca099b9d85e2b090a9520824a68e63d5bfe3537293a750f3c3b5f57de98 WHIRLPOOL 6bb8e586fa2ddc6ef13ed0fc1005d9d537fc1850ce0124a75a93d29e368109c26bacf47c56743fc050c5fb14877dbcfad3b56c1778dbba989e9e9bf06dd313d8
diff --git a/xfce-extra/xfce4-genmon-plugin/metadata.xml b/xfce-extra/xfce4-genmon-plugin/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/xfce4-genmon-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild
new file mode 100644
index 000000000000..aae3e2ca03c8
--- /dev/null
+++ b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Cyclically spawns the executable, captures its output and displays the result into the panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${PV%.*}
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}