summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libzip/libzip-1.7.3-r1.ebuild2
-rw-r--r--eclass/distutils-r1.eclass6
-rw-r--r--eclass/python-utils-r1.eclass40
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild2
-rw-r--r--www-apps/moodle/Manifest6
-rw-r--r--www-apps/moodle/moodle-3.10.4.ebuild (renamed from www-apps/moodle/moodle-3.10.3-r1.ebuild)0
-rw-r--r--www-apps/moodle/moodle-3.5.18-r1.ebuild120
-rw-r--r--www-apps/moodle/moodle-3.8.9-r1.ebuild120
-rw-r--r--www-apps/moodle/moodle-3.9.7.ebuild (renamed from www-apps/moodle/moodle-3.9.6-r1.ebuild)0
9 files changed, 46 insertions, 250 deletions
diff --git a/dev-libs/libzip/libzip-1.7.3-r1.ebuild b/dev-libs/libzip/libzip-1.7.3-r1.ebuild
index 889bec7371ec..4d7fa7066ed1 100644
--- a/dev-libs/libzip/libzip-1.7.3-r1.ebuild
+++ b/dev-libs/libzip/libzip-1.7.3-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://www.nih.at/libzip/${P}.tar.xz"
LICENSE="BSD"
SLOT="0/5"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="bzip2 gnutls lzma mbedtls ssl static-libs test tools"
REQUIRED_USE="test? ( tools )"
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index cc0416fb1d9e..a26130f7a194 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -776,10 +776,8 @@ _distutils-r1_wrap_scripts() {
local basename=${f##*/}
debug-print "${FUNCNAME}: installing wrapper at ${bindir}/${basename}"
- local dosym=dosym
- [[ ${EAPI} == [67] ]] && dosym=dosym8
- "${dosym}" -r "${path#${D}}"/usr/lib/python-exec/python-exec2 \
- "${path#${D}}${bindir#${EPREFIX}}/${basename}"
+ _python_ln_rel "${path}${EPREFIX}"/usr/lib/python-exec/python-exec2 \
+ "${path}${bindir}/${basename}" || die
done
for f in "${non_python_files[@]}"; do
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 7488802332f6..7022d3b7d88a 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -549,6 +549,46 @@ python_get_scriptdir() {
echo "${PYTHON_SCRIPTDIR}"
}
+# @FUNCTION: _python_ln_rel
+# @USAGE: <from> <to>
+# @INTERNAL
+# @DESCRIPTION:
+# Create a relative symlink.
+_python_ln_rel() {
+ debug-print-function ${FUNCNAME} "${@}"
+
+ local target=${1}
+ local symname=${2}
+
+ local tgpath=${target%/*}/
+ local sympath=${symname%/*}/
+ local rel_target=
+
+ while [[ ${sympath} ]]; do
+ local tgseg= symseg=
+
+ while [[ ! ${tgseg} && ${tgpath} ]]; do
+ tgseg=${tgpath%%/*}
+ tgpath=${tgpath#${tgseg}/}
+ done
+
+ while [[ ! ${symseg} && ${sympath} ]]; do
+ symseg=${sympath%%/*}
+ sympath=${sympath#${symseg}/}
+ done
+
+ if [[ ${tgseg} != ${symseg} ]]; then
+ rel_target=../${rel_target}${tgseg:+${tgseg}/}
+ fi
+ done
+ rel_target+=${tgpath}${target##*/}
+
+ debug-print "${FUNCNAME}: ${symname} -> ${target}"
+ debug-print "${FUNCNAME}: rel_target = ${rel_target}"
+
+ ln -fs "${rel_target}" "${symname}"
+}
+
# @FUNCTION: python_optimize
# @USAGE: [<directory>...]
# @DESCRIPTION:
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild
index 6c945aa8c0d3..fc75ac55ef41 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://github.com/besser82/libxcrypt"
LICENSE="LGPL-2.1+ public-domain BSD BSD-2"
SLOT="0/1"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="+compat split-usr +static-libs system test"
DEPEND="system? (
diff --git a/www-apps/moodle/Manifest b/www-apps/moodle/Manifest
index 2d14e2de188d..63e6b7863ec7 100644
--- a/www-apps/moodle/Manifest
+++ b/www-apps/moodle/Manifest
@@ -1,5 +1,3 @@
-DIST moodle-3.10.3.tgz 57483053 BLAKE2B a5129f45c4fdf101df7c96885a8c5cec7cad797a545d5a3fae621f5868cafcf3e9f1cdf06f16e689ccfe0e2bcab6fabd65a5fd45ef178f313176ca5e23350cd9 SHA512 934d42b6fc29c2c9ebcddf788c3e983c3bade77f5d2dbb28a612b17d263a67fd08c0f2a5983bbc1a87054d965cabc3c7257a940febec73f1df72bc7e586cd321
+DIST moodle-3.10.4.tgz 57525833 BLAKE2B c95ec10571d6841059f59f311e7d003b7b5d1b54f08c76bb90edc4efa9abda96b826064e80d5ec86bbdb9299148d8b261bd6183b49d47e69a586165e759da962 SHA512 c524f1940f9b0631f3cd53d1a8f1c43ac05e98e9293ffac649603b9665f3ac78db96152d23b3f8350ebd9ab6264bd544fbf69c164f93d9374a2f0f81af075660
DIST moodle-3.11.tgz 59365522 BLAKE2B f9a2f77dd851efd740b924e51de6b882955101834ca4201bf2fd243ddd8dbe403d1054dcebb5c3022e941fe9f7d119b285d6e955cdb871288cb3b0e40eb9de07 SHA512 69509d57990bf9cca7a262b78f6beb0d90d89e5d93018fd306f662d32303dd39cc0a14b2eee0d58e8f420766cf0acbeeaf6e1f7d43de6b99d0999747b438ee5a
-DIST moodle-3.5.18.tgz 46812954 BLAKE2B fc13835e9d40236b2d572f344870999cd9ea60d11a043428acacc34362fbf114c2253083a6165dc800bca9c5cbb9cefeb4f7f76111a880348bf7b0988cdda8c7 SHA512 8336ba4dd638410e0697e1ee0c9715f166d934ae1325079e5b14e6e7959e32426103bb1af1e1e80ced3764e5c49ccea254de590f729762e417b21dab3f1b849c
-DIST moodle-3.8.9.tgz 53320016 BLAKE2B 5c0c54f5a57eea97c591d75088fe89e8e12df1e233f99c7025fb4e3720a27aa8133ccd25b25876faf2335497827ca748579607dbb2d52c01043fd59854f6dba4 SHA512 ec0bc22d82ae2afb69d491df75011568dba771cc2cbab988dbfe9bc1c4daa6d5e947ca8b9d71acabecd9c57d25202d79321abf1cdda6908ad32511db6c107289
-DIST moodle-3.9.6.tgz 57105713 BLAKE2B 26b5334eda2fac641020459b8471db692f7202acc62b72e11a43fdb3893dadcf2150af7c82659c408ab9ee4660b766498c2c3005f8b43ed980ecefd60263e581 SHA512 0c66070f9cf422a6ed11ac6ff067aba294bc7f4d4b5a17f729c4e4fbb060b59ee232a4a87996557afaa7c6646bfcc3c14736ff4cb18b20a8a31386cc40a61d7f
+DIST moodle-3.9.7.tgz 57157463 BLAKE2B 359d93fdfe62e1470fd7036d2c1d778ce7643c90e70e48a70033bf341833616b8909e6b36d54ddd8f63d38239bfffb709b6fdb50800440c9fc86329132e54f6f SHA512 71caf4408237ae59a5c70be7cbcc245580ed8eb382f03fb4d5284d946f1190fc48aa6562486fa9538c374b760fd05a0bdb95cac5ae182e7787d2e379e51caad6
diff --git a/www-apps/moodle/moodle-3.10.3-r1.ebuild b/www-apps/moodle/moodle-3.10.4.ebuild
index c6650ea73158..c6650ea73158 100644
--- a/www-apps/moodle/moodle-3.10.3-r1.ebuild
+++ b/www-apps/moodle/moodle-3.10.4.ebuild
diff --git a/www-apps/moodle/moodle-3.5.18-r1.ebuild b/www-apps/moodle/moodle-3.5.18-r1.ebuild
deleted file mode 100644
index 0e98b0c6fc9b..000000000000
--- a/www-apps/moodle/moodle-3.5.18-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit webapp
-
-MY_BRANCH="stable$(ver_cut 1)$(ver_cut 2)"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="https://moodle.org"
-SRC_URI="https://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-3+"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,mssql?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS="ctype,curl,iconv,json(+),session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-
-# No forced dependency on
-# mssql? - lives on a windows server
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-9* )
-# which may live on another server. These USE flags affect the configuration
-# file and the dependency on php. However other dbs are possible. See config.php
-# and the moodle documentation for other possibilities.
-DEPEND=""
-RDEPEND="
- >=dev-lang/php-7.0[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- if [[ ${DB_COUNT} -eq 0 ]]; then
- eerror
- eerror "No database selected in your USE flags,"
- eerror "You must select at least one."
- eerror
- die
- fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config-r1.php config.php
-
- # Moodle expect pgsql, not postgres
- MYDB=${MYDB/postgres/pgsql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-
- eapply_user
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo
-}
diff --git a/www-apps/moodle/moodle-3.8.9-r1.ebuild b/www-apps/moodle/moodle-3.8.9-r1.ebuild
deleted file mode 100644
index 8b7fe571d395..000000000000
--- a/www-apps/moodle/moodle-3.8.9-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit webapp
-
-MY_BRANCH="stable$(ver_cut 1)$(ver_cut 2)"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="https://moodle.org"
-SRC_URI="https://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-3+"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,mssql?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS="ctype,curl,iconv,json(+),session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-
-# No forced dependency on
-# mssql? - lives on a windows server
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-9* )
-# which may live on another server. These USE flags affect the configuration
-# file and the dependency on php. However other dbs are possible. See config.php
-# and the moodle documentation for other possibilities.
-DEPEND=""
-RDEPEND="
- >=dev-lang/php-7.1[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- if [[ ${DB_COUNT} -eq 0 ]]; then
- eerror
- eerror "No database selected in your USE flags,"
- eerror "You must select at least one."
- eerror
- die
- fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config-r1.php config.php
-
- # Moodle expect pgsql, not postgres
- MYDB=${MYDB/postgres/pgsql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-
- eapply_user
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo
-}
diff --git a/www-apps/moodle/moodle-3.9.6-r1.ebuild b/www-apps/moodle/moodle-3.9.7.ebuild
index c6650ea73158..c6650ea73158 100644
--- a/www-apps/moodle/moodle-3.9.6-r1.ebuild
+++ b/www-apps/moodle/moodle-3.9.7.ebuild