summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fs/Manifest2
-rw-r--r--dev-python/fs/fs-2.4.13.ebuild15
-rw-r--r--dev-python/pyftpdlib/metadata.xml1
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild22
-rw-r--r--eclass/python-utils-r1.eclass7
5 files changed, 28 insertions, 19 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
index e9e14df3abdc..33c0799877ce 100644
--- a/dev-python/fs/Manifest
+++ b/dev-python/fs/Manifest
@@ -1 +1 @@
-DIST fs-2.4.13.tar.gz 176958 BLAKE2B 154761ddc4db087abdb294ec82ac5b18c46e05f04e783559f3b4d65cde21b9444100130c29d1051a3d2b177f5c9ef7299806fcce1ab3a4b0770b4f1c156abd71 SHA512 c07bf6a8d373a11019709ada392153dbf953399631fa388433f9b7b73d9ae1072ea70b8ed9896752161a4737a399520f030b7875dc23137f418268c5acc24f48
+DIST pyfilesystem2-2.4.13.tar.gz 176958 BLAKE2B 154761ddc4db087abdb294ec82ac5b18c46e05f04e783559f3b4d65cde21b9444100130c29d1051a3d2b177f5c9ef7299806fcce1ab3a4b0770b4f1c156abd71 SHA512 c07bf6a8d373a11019709ada392153dbf953399631fa388433f9b7b73d9ae1072ea70b8ed9896752161a4737a399520f030b7875dc23137f418268c5acc24f48
diff --git a/dev-python/fs/fs-2.4.13.ebuild b/dev-python/fs/fs-2.4.13.ebuild
index 99833ddeba7d..f3878bd3acdd 100644
--- a/dev-python/fs/fs-2.4.13.ebuild
+++ b/dev-python/fs/fs-2.4.13.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 optfeature
-MY_PN="pyfilesystem2"
+MY_P=pyfilesystem2-${PV}
DESCRIPTION="Filesystem abstraction layer"
HOMEPAGE="
https://pypi.org/project/fs/
@@ -17,8 +17,10 @@ HOMEPAGE="
"
# Tests from the PyPI tarball are broken
# https://github.com/PyFilesystem/pyfilesystem2/issues/364
-SRC_URI="https://github.com/PyFilesystem/pyfilesystem2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
+SRC_URI="
+ https://github.com/PyFilesystem/pyfilesystem2/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
@@ -39,6 +41,11 @@ BDEPEND="
distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
+python_test() {
+ # pytest-xvfb causes test failures due to a zombie Xvfb process
+ epytest -p no:xvfb
+}
+
pkg_postinst() {
optfeature "S3 support" dev-python/boto
optfeature "SFTP support" dev-python/paramiko
diff --git a/dev-python/pyftpdlib/metadata.xml b/dev-python/pyftpdlib/metadata.xml
index 1a0a7b81d04c..f2383d4b66ac 100644
--- a/dev-python/pyftpdlib/metadata.xml
+++ b/dev-python/pyftpdlib/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pyftpdlib</remote-id>
<remote-id type="github">giampaolo/pyftpdlib</remote-id>
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
index 919f9cb3f630..f6e04c744b72 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -15,24 +15,24 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="examples ssl test"
-RESTRICT="!test? ( test )"
+IUSE="examples ssl"
RDEPEND="
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
"
BDEPEND="
test? (
- ${RDEPEND}
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
+distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
python_test() {
+ cd "${BUILD_DIR}"/lib || die
+
# These tests fail when passing additional options to pytest
# so we need to run them separately and not pass any args to pytest
pytest ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
@@ -40,16 +40,9 @@ python_test() {
local skipped_tests=(
# Those tests are run separately
pyftpdlib/test/test_misc.py
- # https://github.com/giampaolo/pyftpdlib/issues/470
- # https://bugs.gentoo.org/659108
- pyftpdlib/test/test_functional_ssl.py::TestTimeouts::test_idle_data_timeout2
- pyftpdlib/test/test_functional_ssl.py::TestTimeoutsTLSMixin::test_idle_data_timeout2
# https://github.com/giampaolo/pyftpdlib/issues/471
# https://bugs.gentoo.org/636410
pyftpdlib/test/test_functional.py::TestCallbacks::test_on_incomplete_file_received
- # https://github.com/giampaolo/pyftpdlib/issues/466
- # https://bugs.gentoo.org/659786
- pyftpdlib/test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
# https://github.com/giampaolo/pyftpdlib/issues/512
# https://bugs.gentoo.org/701146
pyftpdlib/test/test_functional_ssl.py::TestFtpStoreDataTLSMixin::test_rest_on_stor
@@ -74,7 +67,10 @@ python_test() {
pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptionsTLSMixin::test_masquerade_address_map
)
# Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
- TZ=UTC+1 epytest -p no:xvfb ${skipped_tests[@]/#/--deselect }
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ epytest -p no:xvfb ${skipped_tests[@]/#/--deselect }
}
python_install_all() {
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 168c767a2eea..b104b6694ac3 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -1272,7 +1272,12 @@ epytest() {
echo "${@}" >&2
"${@}" || die -n "pytest failed with ${EPYTHON}"
- return ${?}
+ local ret=${?}
+
+ # remove common temporary directories left over by pytest plugins
+ rm -rf .hypothesis .pytest_cache || die
+
+ return ${ret}
}
# @FUNCTION: eunittest