summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/dhex/dhex-0.68.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-editors/dhex/dhex-0.68.ebuild b/app-editors/dhex/dhex-0.68.ebuild
index c8f3f05aa651..c2887641967b 100644
--- a/app-editors/dhex/dhex-0.68.ebuild
+++ b/app-editors/dhex/dhex-0.68.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils toolchain-funcs
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~mips x86"
IUSE=""
-DEPEND="sys-libs/ncurses"
+DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
@@ -27,7 +27,9 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)"
+ emake \
+ CC="$(tc-getCC)" \
+ LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
}
src_install() {