summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch b/dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch
index 8481657b8666..e62cc15db238 100644
--- a/dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch
+++ b/dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch
@@ -4,25 +4,25 @@ Date: Fri, 22 Apr 2016 13:42:26 +0500
Subject: [PATCH] Fixing underlinking for gcc 4.9
Allegro4 backend uses XGrabPointer() from libX11.
-Added ${X11_LIBRARIES} for she to resolve underlinking.
+Added ${X11_LIBRARIES} to resolve underlinking.
---
src/she/CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/she/CMakeLists.txt b/src/she/CMakeLists.txt
index cddf5bc..1841aa6 100644
---- a/src/she/CMakeLists.txt
-+++ b/src/she/CMakeLists.txt
-@@ -242,7 +242,8 @@ if(USE_ALLEG4_BACKEND)
- target_link_libraries(she
- ${LOADPNG_LIBRARY}
- ${LIBALLEGRO4_LINK_FLAGS}
-- ${DXGUID_LIBRARIES})
-+ ${DXGUID_LIBRARIES}
-+ ${X11_LIBRARIES})
- endif()
-
- if(USE_SKIA_BACKEND)
+--- a/src/she/CMakeLists.txt.orig 2016-04-30 10:36:25.198000000 +0000
++++ b/src/she/CMakeLists.txt 2016-04-30 10:37:01.163000000 +0000
+@@ -241,7 +241,8 @@
+ target_link_libraries(she
+ ${LOADPNG_LIBRARY}
+ ${LIBALLEGRO4_LINK_FLAGS}
+- ${DXGUID_LIBRARIES})
++ ${DXGUID_LIBRARIES},
++ ${X11_LIBRARIES})
+ endif()
+
+ if(USE_SKIA_BACKEND)
--
2.7.3