summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild b/x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild
index 9a6bd8488cca..47fafd1df54c 100644
--- a/x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild
+++ b/x11-plugins/gkrellm-bluez/gkrellm-bluez-0.2-r2.ebuild
@@ -1,32 +1,33 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin
DESCRIPTION="GKrellm plugin for monitoring bluetooth (Linux BlueZ) adapters"
SRC_URI="mirror://sourceforge/gkrellm-bluez/${P}.tar.gz"
HOMEPAGE="http://gkrellm-bluez.sourceforge.net"
-RDEPEND="
- app-admin/gkrellm[X]
- net-wireless/bluez
-"
-
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-SLOT="0"
-PLUGIN_SO="src/.libs/gkrellmbluez.so"
-PLUGIN_DOCS="THEMING NEWS"
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ net-wireless/bluez"
+DEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-notheme.patch )
+
+PLUGIN_SO=( src/.libs/gkrellmbluez$(get_modname) )
+PLUGIN_DOCS=( THEMING NEWS )
src_prepare() {
default
# Be a bit more future proof, bug #260948
- sed "s/-Werror//" -i src/Makefile.am src/Makefile.in || die "sed failed"
-
- eapply "${FILESDIR}"/${P}-notheme.patch || die "Patch failed"
+ sed "s/-Werror//" -i src/Makefile.am src/Makefile.in || die
}
src_configure() {