summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/ngircd/Manifest1
-rw-r--r--net-irc/ngircd/ngircd-26.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/net-irc/ngircd/Manifest b/net-irc/ngircd/Manifest
index 70e98c6c205f..9185b2f3424f 100644
--- a/net-irc/ngircd/Manifest
+++ b/net-irc/ngircd/Manifest
@@ -1,2 +1,3 @@
DIST ngircd-24.tar.gz 524968 BLAKE2B 8ec0518d54f43a4c42fbf9744d217eb2aae498fe4f0010bce6ad68164037c2e55dc2b9681babce8ca5f7e26bac60a91389c63dab397d349dd4bcbcce6c2e9839 SHA512 66d1b9576c03d0a70be17a235f2da50ee661646cd428d18a6c61975407671dd4a3a545069258536773b27d4fb63523527366bbbf4f35cb08111dc60842924395
DIST ngircd-25.tar.gz 527886 BLAKE2B ab75c9a904fae8da4c89e07bd66bb000bc9b614e27269be3ac6f55254c77abeb2d6f7d0afc6d05630f7c548ea13d842d4c0376123035f9417eda55565a69dcec SHA512 0c96e97da312fe86c50007a72db03f85b9f79df053806f50badd07c7ca8e8bddd99adb478eab8be9630330707d7aa578b5d0bd3017b59bf4515319a64c29ea6c
+DIST ngircd-26.tar.gz 565579 BLAKE2B edd005179a79bbb51a1401f7d580ebf66cb5bf65d1427453c471a4e7e667d7fd6b320c292e9a7993c5fef6beeae88126fefb73284063451b080ecc0d3e6ca0f1 SHA512 2502baf83e3bfca3e6b83c22fe660fee24732ee875b32a7071a489a8babcc08124738142215b55d4f9bd4e94bec3f2a41889ab18324f772b1674b02883cbfb91
diff --git a/net-irc/ngircd/ngircd-26.ebuild b/net-irc/ngircd/ngircd-26.ebuild
new file mode 100644
index 000000000000..06a17a180d81
--- /dev/null
+++ b/net-irc/ngircd/ngircd-26.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Bug: https://github.com/ngircd/ngircd/issues/261
+WANT_AUTOMAKE=1.11.6
+inherit autotools
+
+DESCRIPTION="An IRC server written from scratch"
+HOMEPAGE="https://ngircd.barton.de/"
+SRC_URI="https://arthur.barton.de/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="debug gnutls ident irc-plus +ipv6 libressl pam +ssl strict-rfc tcpd test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/ngircd
+ acct-group/ngircd
+ irc-plus? ( virtual/libiconv )
+ ident? ( net-libs/libident )
+ pam? ( sys-libs/pam )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+ zlib? ( sys-libs/zlib )
+"
+
+BDEPEND="sys-devel/automake:1.11"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-tcltk/expect
+ net-misc/netkit-telnetd
+ )
+"
+
+# Flaky test needs investigation (bug 719256)
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ if ! use prefix; then
+ sed -i \
+ -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+ -e "s:;ServerGID = 65534:ServerGID = ngircd:" \
+ doc/sample-ngircd.conf.tmpl || die
+ fi
+
+ # Once https://github.com/ngircd/ngircd/pull/270 is in a release (ngircd 26), we can remove
+ # the eautomake/autotools machinery.
+ eautomake
+}
+
+src_configure() {
+ local myconf=(
+ --sysconfdir="${EPREFIX}"/etc/"${PN}"
+ $(use_enable debug sniffer)
+ $(use_enable debug)
+ $(use_enable irc-plus ircplus)
+ $(use_enable ipv6)
+ $(use_enable strict-rfc)
+ $(use_with irc-plus iconv)
+ $(use_with ident)
+ $(use_with pam)
+ $(use_with tcpd tcp-wrappers)
+ $(use_with zlib)
+ )
+
+ if use ssl; then
+ if use gnutls; then
+ myconf+=(
+ $( use_with gnutls )
+ )
+ else
+ myconf+=(
+ $( use_with !gnutls openssl )
+ )
+ fi
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/ngircd.init-r1.d ngircd
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] && use pam; then
+ elog "ngircd will use PAMIsOptionalPAM by default, please change this option."
+ elog "You may not be able to login until you change this."
+ fi
+}