summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/freetype/freetype-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/freetype/freetype-9999.ebuild b/media-libs/freetype/freetype-9999.ebuild
index 62dcbc706372..e9f895c9ce0b 100644
--- a/media-libs/freetype/freetype-9999.ebuild
+++ b/media-libs/freetype/freetype-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -42,9 +42,6 @@ DEPEND="${RDEPEND}
PDEPEND="infinality? ( media-libs/fontconfig-infinality )"
PATCHES=(
- # This is the same as the 01 patch from infinality
- "${FILESDIR}"/${PN}-2.7-enable-valid.patch
-
"${FILESDIR}"/${PN}-2.4.11-sizeof-types.patch # 459966
)
@@ -97,6 +94,9 @@ src_prepare() {
default
+ # This is the same as the 01 patch from infinality
+ sed '/AUX_MODULES += \(gx\|ot\)valid/s@^# @@' -i modules.cfg || die
+
enable_option() {
sed -i -e "/#define $1/ { s:/\* ::; s: \*/:: }" \
include/${PN}/config/ftoption.h \
@@ -150,7 +150,7 @@ src_prepare() {
# we need non-/bin/sh to run configure
if [[ -n ${CONFIG_SHELL} ]] ; then
- sed -i -e "1s:^#![[:space:]]*/bin/sh:#!$CONFIG_SHELL:" \
+ sed -i -e "1s:^#![[:space:]]*/bin/sh:#!${CONFIG_SHELL}:" \
"${S}"/builds/unix/configure || die
fi