summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.11.2-qt-5.7.patch26
-rw-r--r--kde-plasma/kdeplasma-addons/kdeplasma-addons-5.11.2.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.11.2-qt-5.7.patch b/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.11.2-qt-5.7.patch
new file mode 100644
index 000000000000..b4afa3c04f5e
--- /dev/null
+++ b/kde-plasma/kdeplasma-addons/files/kdeplasma-addons-5.11.2-qt-5.7.patch
@@ -0,0 +1,26 @@
+From 961078337c823e22691d74925a698d1f28f20ac0 Mon Sep 17 00:00:00 2001
+From: Kai Uwe Broulik <kde@privat.broulik.de>
+Date: Wed, 25 Oct 2017 12:36:08 +0200
+Subject: Use wakeOne() instead of notify_one()
+
+The latter was only introduced in Qt 5.8
+---
+ runners/dictionary/dictionarymatchengine.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/runners/dictionary/dictionarymatchengine.cpp b/runners/dictionary/dictionarymatchengine.cpp
+index 85346d5..27d2228 100644
+--- a/runners/dictionary/dictionarymatchengine.cpp
++++ b/runners/dictionary/dictionarymatchengine.cpp
+@@ -73,7 +73,7 @@ void DictionaryMatchEngine::dataUpdated(const QString &source, const Plasma::Dat
+ /* Because of QString's CoW semantics, we don't have to worry about
+ * the overhead of assigning this to every item. */
+ data->definition = definition;
+- data->waitCondition.notify_one();
++ data->waitCondition.wakeOne();
+ }
+ m_wordLock.unlock();
+ }
+--
+cgit v0.11.2
+
diff --git a/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.11.2.ebuild b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.11.2.ebuild
index 881f2a38fd29..79320367019f 100644
--- a/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.11.2.ebuild
+++ b/kde-plasma/kdeplasma-addons/kdeplasma-addons-5.11.2.ebuild
@@ -47,6 +47,8 @@ RDEPEND="${DEPEND}
!kde-plasma/kdeplasma-addons:4
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.7.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package share KDEExperimentalPurpose)