summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.3.0-r1.ebuild22
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r1.ebuild29
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-php/pecl-radius/pecl-radius-1.3.0-r1.ebuild b/dev-php/pecl-radius/pecl-radius-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..3c81c2150452
--- /dev/null
+++ b/dev-php/pecl-radius/pecl-radius-1.3.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="radius"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Provides support for RADIUS authentication (RFC 2865) and accounting (RFC 2866)"
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="php_targets_php5-6? ( dev-lang/php:5.6[pcntl,sockets] )"
diff --git a/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r1.ebuild b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r1.ebuild
new file mode 100644
index 000000000000..9837a06e878a
--- /dev/null
+++ b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="radius"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php7-0 php5-6"
+PHP_EXT_PECL_FILENAME="${PN/pecl-/}-${PV/_beta/b}.tgz"
+PHP_EXT_S="${WORKDIR}/${PHP_EXT_PECL_FILENAME%.tgz}"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Provides support for RADIUS authentication (RFC 2865) and accounting (RFC 2866)"
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+S="${PHP_EXT_S}"
+
+RDEPEND="
+ php_targets_php5-6? ( dev-lang/php:5.6[pcntl,sockets] )
+ php_targets_php7-0? ( dev-lang/php:7.0[pcntl,sockets] )
+"