summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.08.24.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 31d0467516aa..a18c43d3f37b 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.08.19.tar.gz 2329613 SHA256 9094084dceeeea47da3f8a3071c608b81e28f7c1e8c9b3e92da6b55aeeae961f SHA512 db9e6301b28e0904bd1b002e06ae10cbd0ff54907af33f100220e58817ba68728ce28c60620a307228fed9d97e34e53ed25c2b7aad71e92fe1d99fc71d308378 WHIRLPOOL a52048a65359d860c8ab23734ba004558d32f4813e3fd702606c753d23718194923373f984b7d52a2c5cbac116fe9a3c3e5e86c0ca8cb2596db24bb541248046
DIST youtube-dl-2016.08.22.tar.gz 2336310 SHA256 966bd3cac77e43ded412fa965e785763933297f001fe289f509fc6acdd0f6fd1 SHA512 88e7715e7f1438cc02eba551f15646fc1ff831091fefc3ddb95a447c848052312f84a1604d622bf78060aa15f30f9b015a5459feaa5d65a1dcc0ab916842e194 WHIRLPOOL a59aa08427123032bf175b4a7d83cd57f79cc0da0ac55db3462fbbcd2c51f7ff07aa46e07b98f7645064f846ef928f0efc2cbb6aff56b18e0601195f0b8f34da
+DIST youtube-dl-2016.08.24.1.tar.gz 2337744 SHA256 d8ca8fb4dd2b3f90f4db5be44046ce18392dcadee40d3b8e7164cf4552ec99c5 SHA512 dca69704faabc41135f04b8fd943b6234ddae947aa40a6fea7a9a2b881b8f099451bb80afdddb8403fea7d9f785e66e7fbcc8b15fa3a160349b020672cb6973d WHIRLPOOL 9c8c9ecf1393a301c2f8d4433f4c30143f7c5e28c32c205062aed1b56c7bb01abdb8e03f276034b0befdf5d510c7d7ea57310b16bc53e0e38df2a3a0c66b3456
diff --git a/net-misc/youtube-dl/youtube-dl-2016.08.24.1.ebuild b/net-misc/youtube-dl/youtube-dl-2016.08.24.1.ebuild
new file mode 100644
index 000000000000..9d7ca82d0e68
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.08.24.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+}