summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/spyder-notebook/Manifest1
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.2.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
index 27fbd8c39c77..dec9b84ea312 100644
--- a/dev-python/spyder-notebook/Manifest
+++ b/dev-python/spyder-notebook/Manifest
@@ -1 +1,2 @@
DIST spyder-notebook-0.2.2.tar.gz 3691495 BLAKE2B 255df807c553f0d1e1ed9d8e7326e23702e900d15c139467e7e236c911d1412c71a959b5756ba5c538ccb7dbef5c75bbbd744ff2d6acbe701d51d3def9ac0ee8 SHA512 3c76beff7b709b39d1a00bb2a3391f9ee7f0439bfe2a2c49834c4e373488cc7cd690360966ea9b11d2f06cb577f3a62951aa85b00419de3dd3ef276bcbd13597
+DIST spyder-notebook-0.2.3.tar.gz 3692690 BLAKE2B 74fa380233155ef411f1bc6018111d94eb03cdf4d4d3b75937b4e63047320bf2292bb2e4b058efdfe0b2ba78569872e1dbda110b9b7b29c4948a787fb9fde399 SHA512 b2a8f256ea304150477df98f5e6c16c90dbfe42c0bae7eeef9fb25a9de02433a7d8b3bf448926a94df69d6adaeb91e277ebfe7f1a5135d9ac9f9ce2dc9bfd804
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.2.3.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.2.3.ebuild
new file mode 100644
index 000000000000..2b00297233bd
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+# Tests do not work inside virtx/emerge for some reason, core dumped
+RESTRICT="test"
+distutils_enable_tests pytest
+
+pytthon_test() {
+ virtx pytest -vv
+}