summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/iputils/iputils-99999999.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/net-misc/iputils/iputils-99999999.ebuild b/net-misc/iputils/iputils-99999999.ebuild
index 013519142a42..09b9ad107a61 100644
--- a/net-misc/iputils/iputils-99999999.ebuild
+++ b/net-misc/iputils/iputils-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,7 +7,7 @@
# building stages, and when the jade/sgml packages are broken (which
# seems to be more common than would be nice).
-EAPI="4"
+EAPI=5
inherit flag-o-matic eutils toolchain-funcs fcaps
if [[ ${PV} == "99999999" ]] ; then
@@ -15,7 +15,7 @@ if [[ ${PV} == "99999999" ]] ; then
inherit git-2
else
SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2
- mirror://gentoo/iputils-s${PV}-manpages.tar.bz2"
+ https://dev.gentoo.org/~polynomial-c/iputils-s${PV}-manpages.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux"
fi
@@ -24,16 +24,13 @@ HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/networking/iputi
LICENSE="BSD-4"
SLOT="0"
-IUSE="arping caps clockdiff doc gnutls idn ipv6 libressl rarpd rdisc SECURITY_HAZARD ssl static tftpd tracepath traceroute"
+IUSE="arping caps clockdiff doc gcrypt idn ipv6 libressl rarpd rdisc SECURITY_HAZARD ssl static tftpd tracepath traceroute"
LIB_DEPEND="caps? ( sys-libs/libcap[static-libs(+)] )
idn? ( net-dns/libidn[static-libs(+)] )
ipv6? ( ssl? (
- gnutls? (
- net-libs/gnutls[openssl(+)]
- net-libs/gnutls[static-libs(+)]
- )
- !gnutls? (
+ gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
+ !gcrypt? (
!libressl? ( dev-libs/openssl:0[static-libs(+)] )
libressl? ( dev-libs/libressl[static-libs(+)] )
)
@@ -56,14 +53,18 @@ fi
S=${WORKDIR}/${PN}-s${PV}
+PATCHES=(
+ "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
+ "${FILESDIR}"/${PN}-99999999-openssl.patch #335436
+ "${FILESDIR}"/${PN}-99999999-tftpd-syslog.patch
+ "${FILESDIR}"/${PN}-20121221-makefile.patch
+ "${FILESDIR}"/${PN}-20121221-parallel-doc.patch
+ "${FILESDIR}"/${PN}-20121221-strtod.patch #472592
+)
+
src_prepare() {
- epatch "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
- epatch "${FILESDIR}"/${PN}-99999999-openssl.patch #335436
- epatch "${FILESDIR}"/${PN}-99999999-tftpd-syslog.patch
- epatch "${FILESDIR}"/${PN}-20121221-makefile.patch
- epatch "${FILESDIR}"/${PN}-20121221-parallel-doc.patch
- epatch "${FILESDIR}"/${PN}-20121221-strtod.patch #472592
- use SECURITY_HAZARD && epatch "${FILESDIR}"/${PN}-20071127-nonroot-floodping.patch
+ use SECURITY_HAZARD && PATCHES+=( "${FILESDIR}"/${PN}-20071127-nonroot-floodping.patch )
+ epatch "${PATCHES[@]}"
}
src_configure() {
@@ -86,7 +87,7 @@ src_compile() {
emake \
USE_CAP=$(usex caps) \
USE_IDN=$(usex idn) \
- USE_GNUTLS=$(usex gnutls) \
+ USE_GCRYPT=$(usex gcrypt) \
USE_CRYPTO=$(usex ssl) \
IPV4_TARGETS="${IPV4_TARGETS[*]}" \
IPV6_TARGETS="${IPV6_TARGETS[*]}"