summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/insaneodyssey/files/insaneodyssey-000311-gcc6.patch21
-rw-r--r--games-arcade/insaneodyssey/insaneodyssey-000311.ebuild5
2 files changed, 25 insertions, 1 deletions
diff --git a/games-arcade/insaneodyssey/files/insaneodyssey-000311-gcc6.patch b/games-arcade/insaneodyssey/files/insaneodyssey-000311-gcc6.patch
new file mode 100644
index 000000000000..74b4bf644d49
--- /dev/null
+++ b/games-arcade/insaneodyssey/files/insaneodyssey-000311-gcc6.patch
@@ -0,0 +1,21 @@
+Bug: https://bugs.gentoo.org/600894
+
+--- a/insaneodyssey/io.cpp
++++ b/insaneodyssey/io.cpp
+@@ -22,6 +22,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <cmath>
+
+ #include <SDL/SDL.h>
+
+@@ -894,7 +895,7 @@
+ else
+ {
+ if ( jumping )
+- yspeed = -jumpheight - abs(xspeed)/4;
++ yspeed = -jumpheight - std::abs(xspeed)/4;
+ }
+
+ short TempX = (x + width/2) / TILESIZE;
diff --git a/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild b/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
index 2963941b7267..74763f4692e3 100644
--- a/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
+++ b/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -30,6 +30,9 @@ src_prepare() {
"${FILESDIR}"/${P}-datafiles.patch > "${T}"/datafiles.patch \
|| die
epatch "${T}"/datafiles.patch
+
+ epatch "${FILESDIR}"/${P}-gcc6.patch
+
sed -i \
-e "/lvl/s:^:${GAMES_DATADIR}/${PN}/:" \
-e "s:night:${GAMES_DATADIR}/${PN}/night:" \