summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/notmuch-0.23.2.ebuild200
2 files changed, 201 insertions, 0 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index c0f1452a52b0..938e00510f5f 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -5,3 +5,4 @@ DIST notmuch-0.20.2.tar.gz 652945 SHA256 f741a26345bff389fd8a4a119c4174c6585730f
DIST notmuch-0.21.tar.gz 663600 SHA256 d06f8ffed168c7d53ffc449dd611038b5fa90f7ee22d58f3bec3b379571e25b3 SHA512 2485c422433be21f6bf89aaf997e1468c31a52029ddc8336e78a632b292c659569448c29813ea550ed27fb6815558522a451a7fa10e8fb3f87d9538b4dd7b01a WHIRLPOOL 303c6427822272834e3d95ac94760f0fbaf3f2947a984a6770a9b2918fe0fbad289ef95fb9a8300cb6db08ab3ef0ff56810b3a60879c6a2a3eac524689f0a2f0
DIST notmuch-0.22.2.tar.gz 683796 SHA256 6cd19c61634079981b2d8f4b7cb4eb953cba2a36272520603682d813d2bd7ed1 SHA512 cc11feb8d1c2c7959a42e032c1e36e828290a8e8477af8936a27654117fbc2e080c71fe69ec92bd80763d9d3b163d45b7c0fa9fe9c4ec649600fa928110da4ee WHIRLPOOL 6aa41fa26a92a11393193b6f7e147b69de00f57fe712486805b2b7019d9bf9887d6d10962ef4144ca9ef07d6f63bbb1ddb2f7104c6eb89841285620d439743be
DIST notmuch-0.23.1.tar.gz 690069 SHA256 e8012a1aa9afa47dfeb78f826610577e6bf9714e0933f28139c8611aad96d180 SHA512 e19bdc525090abcd4d476e4fd77d22e43001dee9b9202c45877b40d8c76bb9f522df61c19448ca42f6812e23e590e9241bda354c28205f479da50fb3ebd7bbb1 WHIRLPOOL b6f34bfa23aa2ed4d970696d5eedbc9d96f754bc88370bd777a9bafac835caf795df7e7f81e28892a014861bcb1512fd5bbb5ce225058f0cdec1858a167e6668
+DIST notmuch-0.23.2.tar.gz 690833 SHA256 edfd7528d43bf1e1ab2620607f9fdcf772603455a61c2eb49978619c352c97bc SHA512 487f70ef613962275dc81532cea62f287933bdb7a695466ce5ce0c5913ce06597abb152bac7126457997da710bbd716d30cee408a83b6bad4343407a5a9a202e WHIRLPOOL e5057e4490d949462e7f08530176a0b3c32a31e92402210cd02e11cb18c87f33d3e9705edd84284d0622e25a043d35a2d093bd0a0a9007123e87196ab699a885
diff --git a/net-mail/notmuch/notmuch-0.23.2.ebuild b/net-mail/notmuch/notmuch-0.23.2.ebuild
new file mode 100644
index 000000000000..49aefbf3285f
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.23.2.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+ distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
+ test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~x86"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+ "
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+
+CDEPEND="
+ >=app-shells/bash-completion-1.9
+ >=dev-libs/glib-2.22:2
+ >=dev-libs/gmime-2.6.20-r2:2.6
+ >=dev-libs/xapian-1.2.7-r2:=
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ crypt? ( >=dev-libs/gmime-2.6.20-r2:2.6[smime] )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
+ crypt? ( app-crypt/gnupg dev-libs/openssl ) )
+ valgrind? ( dev-util/valgrind )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "There are few not backward compatible changes between"
+ ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
+ ewarn "(0.18 section) for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_unpack() {
+ unpack "${P}".tar.gz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ rm -f Makefile.config # assure that new Makefile.config will be generated
+
+ if use test; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ $(use_with doc api-docs)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ rm -r html/_sources || die
+ rm html/{objects.inv,.buildinfo} || die
+ mkdir -p ../html && mv html ../html/python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/notmuch-report
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dodoc -r html
+}
+
+pkg_preinst() {
+ if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}