summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.3.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 37dde0b37658..6eb9cde47a63 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -7,3 +7,4 @@ DIST flake8-2.5.1.tar.gz 83692 SHA256 448aed48b0671fe6062f47b98c3081f3a4b36fbe99
DIST flake8-2.5.4.tar.gz 81663 SHA256 cc1e58179f6cf10524c7bfdd378f5536d0a61497688517791639a5ecc867492f SHA512 31cbec556fc41361ac464d2547275e319ab663c907a4a8644113a2288a9f349bcfbec85197b6dfa13a7db9e82419f01e0f2abc84a347e133c144ea137e0daa28 WHIRLPOOL 2547b78092b1a85edd2a0d03d9e0bc31e7d3b7cb3958cf5dea9947377851a69d5c37f64c0d65a5d7e88ab9573597729adbe07ae758b0510e455b26bf62292f47
DIST flake8-3.0.4.tar.gz 1382588 SHA256 b4c210c998f07d6ff24325dd91fbc011f2c37bcd6bf576b188de01d8656e970d SHA512 845b38824112edfc8244f6ec795b5659f99b4e8171af5e6c737f345e5a429f7b26f57e24ccc42fa2d8117b7ceff4dd100fe840064260fa17f203804e4b83ab06 WHIRLPOOL 79300674a1a326d95e80208cee664b0ddcd518653cac2aac381a3a32c1bcc40b4ddb00f95b064e119bc7f40098240e77b16898db688b87a2571ad523eac72a44
DIST flake8-3.2.1.tar.gz 129458 SHA256 c7c460b5aff3a2063c798a77af18ec70af3941d35a22e2e76965e3c0e0b36055 SHA512 9ccb4e13d87ae1198466f112138d5ef423f55e9af1d6ab9f14d6927bd40b9d621d1a74e0acd43b1ba4e12cae67d7671dde205c04f5760d760ca9d982655d4ebf WHIRLPOOL a4210bbc535fc6d61853c39ad44e2274963e8854eadaf4236c7edbe5dc367ea31d60f742e5f634b4b1ff0aea55a43aaebd29201cb5dcfc818e94aac4d6d34bf4
+DIST flake8-3.3.0.tar.gz 134345 SHA256 b907a26dcf5580753d8f80f1be0ec1d5c45b719f7bac441120793d1a70b03f12 SHA512 53b3116765f9031c96a0442954f324fe3edaf63aff21f7cf340e47e724250928d6d9786473d2680b695969ef979a8bb6d4d2b39f1598b075dcace1b221a4c099 WHIRLPOOL 1a0f7e228cbfdde18957c43377fd5c07a280628ca75138e76ec295e5567c153e454543e534496ec9217e7ca0389208ae143c3396ca3798b65b0f2ce1d72bd68b
diff --git a/dev-python/flake8/flake8-3.3.0.ebuild b/dev-python/flake8/flake8-3.3.0.ebuild
new file mode 100644
index 000000000000..5557d870bdc6
--- /dev/null
+++ b/dev-python/flake8/flake8-3.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+IUSE="test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+LICENSE="MIT"
+SLOT="0"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' 'pypy*' )
+ >=dev-python/pyflakes-1.5.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-1.6.0[${PYTHON_USEDEP}]
+ !~dev-python/pyflakes-1.2.0
+ !~dev-python/pyflakes-1.2.1
+ !~dev-python/pyflakes-1.2.2
+ >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
+ "
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ || (
+ >dev-python/pytest-3.0.5[${PYTHON_USEDEP}]
+ <dev-python/pytest-3.0.5[${PYTHON_USEDEP}]
+ )
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Gentoo has flake8 support restored in >=pep8-1.6.2-r1.
+ sed -i -e 's:, != 1.6.2::' setup.py || die
+ # Flake8 falsely assumes it needs pytest-runner unconditionally and will
+ # try to install it, causing sandbox violations.
+ sed -i -e "/setup_requires=\['pytest-runner'\],/d" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest || die "tests failed"
+}