summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-rpg/baldurs-gate-ee/Manifest1
-rw-r--r--games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3.ebuild56
-rw-r--r--games-rpg/baldurs-gate-ee/metadata.xml21
-rw-r--r--profiles/arch/amd64/no-multilib/package.mask1
-rw-r--r--profiles/hardened/linux/amd64/no-multilib/package.mask1
5 files changed, 80 insertions, 0 deletions
diff --git a/games-rpg/baldurs-gate-ee/Manifest b/games-rpg/baldurs-gate-ee/Manifest
new file mode 100644
index 000000000000..f79b24057cfc
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/Manifest
@@ -0,0 +1 @@
+DIST gog_baldur_s_gate_enhanced_edition_2.5.0.8.sh 2877122979 SHA256 ddd4ad12a340db1fe74f68532565df216577ffd76ce9190da0a288594b161e7b SHA512 b129e7c8e656092ab731410e0776576f28e497958e84faf02095d0a22ee72a2c8c9d1563b8c972959f6f9d4c2cb9dacd13358d5aee1c53c3f198d9b362c19d3d WHIRLPOOL 730218b67b6f026bbd3f40d2f0d382c60b10be48ca0e13f6d705ca96e6edebe21e0fb3131dd1c07aadf3c7396f56e8dbd55b0c19074bd7564ea7d533cb98ace2
diff --git a/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3.ebuild b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3.ebuild
new file mode 100644
index 000000000000..9dab4cbf46ba
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="Baldur's Gate: Enhanced Edition"
+HOMEPAGE="https://www.baldursgate.com/"
+SRC_URI="gog_baldur_s_gate_enhanced_edition_2.5.0.8.sh"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/expat[abi_x86_32(-)]
+ dev-libs/json-c[abi_x86_32(-)]
+ dev-libs/openssl:0[abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]"
+
+QA_PREBUILT="/opt/${PN}/BaldursGate"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ einfo "Please buy and download \"${SRC_URI}\" from"
+ einfo "https://www.gog.com/game/baldurs_gate_enhanced_edition"
+ einfo "and copy it to \"${DISTDIR}\""
+}
+
+src_unpack() {
+ unpack_zip "${DISTDIR}/${SRC_URI}"
+}
+
+src_install() {
+ local ABI="x86"
+ local dir="/opt/${PN}"
+
+ dodoc -r "game/Manuals/."
+ rm -r "game/Manuals" || die "rm failed"
+
+ insinto "${dir}"
+ doins -r "game/."
+ fperms +x "${dir}/BaldursGate"
+
+ dodir "${dir}/lib"
+ dosym "../../../usr/$(get_libdir)/libjson-c.so" "${dir}/lib/libjson.so.0"
+
+ newicon "support/icon.png" "${PN}.png"
+ make_wrapper ${PN} "./BaldursGate" "${dir}" "${dir}/lib"
+ make_desktop_entry "${PN}" "Baldur's Gate: Enhanced Edition" "${PN}" "Game;RolePlaying"
+}
diff --git a/games-rpg/baldurs-gate-ee/metadata.xml b/games-rpg/baldurs-gate-ee/metadata.xml
new file mode 100644
index 000000000000..09145c6cdfdd
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sir.suriv@gmail.com</email>
+ <name>Diogo Pereira</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Baldur's Gate: Enhanced Edition is a remake of the role-playing video
+ game Baldur's Gate. It takes place in the Forgotten Realms, a high
+ fantasy campaign setting, using a modified version of the Advanced
+ Dungeons &amp; Dragons (AD&amp;D) 2nd edition rules.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://support.baldursgate.com/projects/bg-ee-bugs/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/profiles/arch/amd64/no-multilib/package.mask b/profiles/arch/amd64/no-multilib/package.mask
index 76c485bd2230..31b00d58918f 100644
--- a/profiles/arch/amd64/no-multilib/package.mask
+++ b/profiles/arch/amd64/no-multilib/package.mask
@@ -116,6 +116,7 @@ games-misc/little-inferno
games-misc/papers-please
games-puzzle/hoh-bin
games-roguelike/adom
+games-rpg/baldurs-gate-ee
games-rpg/dear-esther
games-rpg/dungeon-defenders
games-rpg/eschalon-book-1-demo
diff --git a/profiles/hardened/linux/amd64/no-multilib/package.mask b/profiles/hardened/linux/amd64/no-multilib/package.mask
index 3bc7a0be28af..9aff5953aea0 100644
--- a/profiles/hardened/linux/amd64/no-multilib/package.mask
+++ b/profiles/hardened/linux/amd64/no-multilib/package.mask
@@ -112,6 +112,7 @@ games-misc/little-inferno
games-puzzle/hoh-bin
games-roguelike/adom
<games-roguelike/dwarf-fortress-0.43.0
+games-rpg/baldurs-gate-ee
games-rpg/dear-esther
games-rpg/eschalon-book-1-demo
games-rpg/nwmouse