summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.6.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 91042baaefb2..0af60a7f0426 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,2 +1,3 @@
DIST qsynth-0.6.0.tar.gz 316308 BLAKE2B d414c73d5baf3be1563c45390735de964c79774a4d7cc37ff4bc609a7fa4d291a5b0cba7f3b8ed52649c50325a3ba2fba7baad3943122cc76a98aa6cfdf2cb0f SHA512 34e15d283f403ec6633fef911285dc2d4d4b2c5a0cd3614bd38feefbf68cff5fd8e296f47d1bcd527658b8a9dab212106aa63ca71ea60cf49f8126adb7d28591
DIST qsynth-0.6.1.tar.gz 337277 BLAKE2B c0f160bc4a1db84a53fb96fe66212b335a07736f6659514a61a20e9d23a95e50bee5818443035095e262f45a38d09b59aff10062cfc121c75a20e2b57a488aef SHA512 597ec51f2f2bc45e717dd6e039d10ace3540c6e7332832cbd36a16fb05b88248a59e5ba107369c8bd66d29060c31d0daef13f4967794e2f7b55c85a64dcd6e0c
+DIST qsynth-0.6.2.tar.gz 383146 BLAKE2B 6e93a1d16dc57ce5cc180932eec049cbd62eb64d6667cbfc748c474fe2b751273ff50a94a5497f1d268e2d413831095bea92a2f086b417625f02fecf1bc6ec9d SHA512 6e6f5dc64c39ab18ad1a9e791376e0dcf6eea4882986b1723a5a2f7c53309ce166d443a198c62b33ac31ed3fc17100c3a4f8e3b1e474b70afcec0ffa7f1ffc08
diff --git a/media-sound/qsynth/qsynth-0.6.2.ebuild b/media-sound/qsynth/qsynth-0.6.2.ebuild
new file mode 100644
index 000000000000..71cbc9eebd10
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.6.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic qmake-utils xdg-utils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
+ econf \
+ $(use_enable debug)
+
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${ED}/usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}