summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/devhelp/Manifest1
-rw-r--r--dev-util/devhelp/devhelp-3.28.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/devhelp/Manifest b/dev-util/devhelp/Manifest
index 3bd945fe01c1..0f972a5e897f 100644
--- a/dev-util/devhelp/Manifest
+++ b/dev-util/devhelp/Manifest
@@ -1,2 +1,3 @@
DIST devhelp-3.24.0.tar.xz 615460 BLAKE2B b81ac9b1453c0edff45fa746a556343345a150c6436d68db4d51f716704eca70e7aa1af4f3deb5b5c2747db65de619be119f36af807490aa8f95fd070c68cc39 SHA512 56b1eeaf9d3c3357d3140002bed5c29bf7b21953d964405190a1c9cad69d08000efa0220bbc36c67db4151b15ee37c37e061e6fa63c8a79f626e1ec0ce386062
DIST devhelp-3.26.1.tar.xz 613508 BLAKE2B a84d6bb55a81f0beda0603f343022b997e263934fc48ccc95503e156a0ee0984e1c945af785971c45f197865147c63be354ace72582d3575692dd5eed7e1e724 SHA512 76beec8846703004202229853a7a208b31bf56e2f10c102a3bb6e88fb9e54aded027e6ab9620706629dcb02cf5973f1d4fe88d217a7b3b8cb0efc948b02ca660
+DIST devhelp-3.28.1.tar.xz 642992 BLAKE2B d3b3a2768b33fb47f05d35d9e6fe970d2f42c564c37916123d7377515dfb5a8277c51f543d103d4b34b11d72e3fbf4d7efc63296e118b1b6a6ac5ba557376a02 SHA512 a42208cbb7ad677a9c130eb637bbe52ca9fbdacd6bb7714ea3cd71285ad4983d7131dfab003ffaf0be1faccd04f215ad68429d4dcb7b49dbb0eebc0e10350f0b
diff --git a/dev-util/devhelp/devhelp-3.28.1.ebuild b/dev-util/devhelp/devhelp-3.28.1.ebuild
new file mode 100644
index 000000000000..f613f8f1f72b
--- /dev/null
+++ b/dev-util/devhelp/devhelp-3.28.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+# gedit-3.8 is python3 only, this also per:
+# https://bugzilla.redhat.com/show_bug.cgi?id=979450
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2 python-single-r1 toolchain-funcs
+
+DESCRIPTION="An API documentation browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
+
+LICENSE="GPL-2+"
+SLOT="0/3-5" # subslot = 3-(libdevhelp-3 soname version)
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="gedit +introspection"
+REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2[dbus]
+ >=x11-libs/gtk+-3.22:3
+ >=net-libs/webkit-gtk-2.19.2:4
+ gnome-base/gsettings-desktop-schemas
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gedit? (
+ ${PYTHON_DEPS}
+ app-editors/gedit[introspection,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+[introspection] )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ dev-util/itstool
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+# eautoreconf requires:
+# dev-libs/appstream-glib
+# sys-devel/autoconf-archive
+# app-text/yelp-tools
+
+pkg_setup() {
+ use gedit && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if ! use gedit ; then
+ sed -e '/SUBDIRS/ s/gedit-plugin//' -i plugins/Makefile.{am,in} || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ # ICC is crazy, silence warnings (bug #154010)
+ if [[ $(tc-getCC) == "icc" ]] ; then
+ myconf="--with-compile-warnings=no"
+ fi
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ ${myconf}
+}