summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild')
-rw-r--r--app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild b/app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild
new file mode 100644
index 000000000000..46e33d17179c
--- /dev/null
+++ b/app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/Barzahlen/cronlocker
+HASH=c0ac605
+inherit golang-vcs-snapshot
+
+DESCRIPTION="synchronize a cron job across multiple hosts using the consul lock feature"
+HOMEPAGE="https://github.com/Barzahlen/cronlocker"
+SRC_URI="https://github.com/Barzahlen/${PN}/archive/${HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" emake cronlocker
+}
+
+src_install() {
+ pushd src/${EGO_PN}
+dobin cronlocker
+dodoc *.md package/changelog
+}