summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/dio/dio-1.5.2.ebuild')
-rw-r--r--app-admin/dio/dio-1.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/dio/dio-1.5.2.ebuild b/app-admin/dio/dio-1.5.2.ebuild
new file mode 100644
index 000000000000..8fd1f8038a90
--- /dev/null
+++ b/app-admin/dio/dio-1.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="dio - Device I/O monitoring tool"
+HOMEPAGE="https://github.com/donaldmcintosh/dio"
+SRC_URI="https://github.com/donaldmcintosh/dio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin dio
+ doman dio.1
+}