summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/logrotate/logrotate-3.8.8.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.8.8.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/app-admin/logrotate/logrotate-3.8.8.ebuild b/app-admin/logrotate/logrotate-3.8.8.ebuild
new file mode 100644
index 000000000000..1085ce9e4978
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.8.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://fedorahosted.org/logrotate/"
+SRC_URI="https://fedorahosted.org/releases/l/o/logrotate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ~ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl selinux"
+
+CDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? (
+ sys-libs/libselinux
+ )
+ acl? ( virtual/acl )"
+
+DEPEND="${CDEPEND}
+ >=sys-apps/sed-4
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-logrotate )
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ignore-hidden.patch \
+ "${FILESDIR}"/${P}-fbsd.patch \
+ "${FILESDIR}"/${P}-noasprintf.patch \
+ "${FILESDIR}"/${P}-atomic-create.patch \
+ "${FILESDIR}"/${P}-Werror.patch
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ myconf="CC=$(tc-getCC)"
+ use selinux && myconf="${myconf} WITH_SELINUX=yes"
+ use acl && myconf="${myconf} WITH_ACL=yes"
+ emake ${myconf} RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ insinto /usr
+ dosbin logrotate
+ doman logrotate.8
+ dodoc CHANGES examples/logrotate*
+
+ exeinto /etc/cron.daily
+ newexe "${S}"/examples/logrotate.cron "${PN}"
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+ fi
+}