summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/packagekit-base/files')
-rw-r--r--app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch26
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch17
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch72
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch12
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch13
5 files changed, 140 insertions, 0 deletions
diff --git a/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch b/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch
new file mode 100644
index 000000000000..e24faeec9a50
--- /dev/null
+++ b/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch
@@ -0,0 +1,26 @@
+From ee2dfacb275e8145c7ae1ba8da86779054adf902 Mon Sep 17 00:00:00 2001
+From: Fabio Erculiani <lxnay@sabayon.org>
+Date: Fri, 6 Dec 2013 07:40:15 +0100
+Subject: [PATCH] entropy: PackageKitEntropyClient.output API update
+
+---
+ backends/entropy/entropyBackend.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/backends/entropy/entropyBackend.py b/backends/entropy/entropyBackend.py
+index 57b6c59..bec8ef6 100755
+--- a/backends/entropy/entropyBackend.py
++++ b/backends/entropy/entropyBackend.py
+@@ -776,7 +776,8 @@ class PackageKitEntropyClient(Client):
+ def init_singleton(self):
+ Client.init_singleton(self, url_fetcher = PkUrlFetcher)
+
+- def output(self, text, header = "", footer = "", back = False,
++ @classmethod
++ def output(cls, text, header = "", footer = "", back = False,
+ importance = 0, level = "info", count = None, percent = False):
+ """
+ Reimplemented from entropy.output.TextInterface.
+--
+1.8.4.4
+
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch
new file mode 100644
index 000000000000..5c96e51a60ec
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch
@@ -0,0 +1,17 @@
+--- a/contrib/browser-plugin/pk-main.c
++++ b/contrib/browser-plugin/pk-main.c
+@@ -503,11 +503,11 @@ NP_Shutdown ()
+ /**
+ * NP_GetMIMEDescription:
+ **/
+-const char *
++char *
+ NP_GetMIMEDescription (void)
+ {
+ g_debug ("NP_GetMIMEDescription");
+- return (const gchar*) "application/x-packagekit-plugin:bsc:PackageKit Plugin";
++ return (gchar*) "application/x-packagekit-plugin:bsc:PackageKit Plugin";
+ }
+
+ /**
+
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch
new file mode 100644
index 000000000000..c3e034d75ff6
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch
@@ -0,0 +1,72 @@
+--- PackageKit-0.7.4.orig/configure
++++ PackageKit-0.7.4/configure
+@@ -20283,14 +20283,14 @@ if test -n "$PK_BROWSER_PLUGIN_CFLAGS";
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\\
+- mozilla-plugin >= 8.0 \\
++ npapi-sdk \\
+ gio-unix-2.0 \\
+ nspr >= 4.8 \\
+ cairo \\
+ pango \\
+ gtk+-2.0 >= 2.14.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20300,7 +20300,7 @@ if test -n "$PK_BROWSER_PLUGIN_CFLAGS";
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_PK_BROWSER_PLUGIN_CFLAGS=`$PKG_CONFIG --cflags "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20317,14 +20317,14 @@ if test -n "$PK_BROWSER_PLUGIN_LIBS"; th
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\\
+- mozilla-plugin >= 8.0 \\
++ npapi-sdk \\
+ gio-unix-2.0 \\
+ nspr >= 4.8 \\
+ cairo \\
+ pango \\
+ gtk+-2.0 >= 2.14.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20334,7 +20334,7 @@ if test -n "$PK_BROWSER_PLUGIN_LIBS"; th
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_PK_BROWSER_PLUGIN_LIBS=`$PKG_CONFIG --libs "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20360,7 +20360,7 @@ else
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+ PK_BROWSER_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20368,7 +20368,7 @@ fi
+ gtk+-2.0 >= 2.14.0" 2>&1`
+ else
+ PK_BROWSER_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch b/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch
new file mode 100644
index 000000000000..69a0fd7e5f49
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch
@@ -0,0 +1,12 @@
+Index: PackageKit-0.8.12/src/org.freedesktop.PackageKit.xml
+===================================================================
+--- PackageKit-0.8.12.orig/src/org.freedesktop.PackageKit.xml
++++ PackageKit-0.8.12/src/org.freedesktop.PackageKit.xml
+@@ -317,6 +317,7 @@
+
+ <!--*****************************************************************************************-->
+ <method name="GetPackageHistory">
++ <annotation name="org.qtproject.QtDBus.QtTypeName.Out0" value="QVariant"/>
+ <doc:doc>
+ <doc:description>
+ <doc:para>
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch b/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch
new file mode 100644
index 000000000000..59b3ab109648
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 3e8d301..7ba7f4b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -361,7 +361,7 @@ AC_ARG_ENABLE(browser_plugin, AS_HELP_STRING([--enable-browser-plugin],[Build br
+ enable_browser_plugin=$enableval,enable_browser_plugin=yes)
+ if test x$enable_browser_plugin = xyes; then
+ PKG_CHECK_MODULES(PK_BROWSER_PLUGIN, \
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \