summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwgen/pwgen-2.07.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.07.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/pwgen/pwgen-2.07.ebuild b/app-admin/pwgen/pwgen-2.07.ebuild
new file mode 100644
index 000000000000..4d652df71aab
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.07.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="livecd"
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.06-special-char.patch
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/etc/pwgen
+}
+
+src_install() {
+ default
+ use livecd && newinitd "${FILESDIR}"/pwgen.rc pwgen
+}