summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sud/sud-1.3-r1.ebuild')
-rw-r--r--app-admin/sud/sud-1.3-r1.ebuild31
1 files changed, 10 insertions, 21 deletions
diff --git a/app-admin/sud/sud-1.3-r1.ebuild b/app-admin/sud/sud-1.3-r1.ebuild
index ef9d6f7005de..7c72435d9c4d 100644
--- a/app-admin/sud/sud-1.3-r1.ebuild
+++ b/app-admin/sud/sud-1.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=6
-inherit eutils flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="A daemon to execute processes with special privileges in a nosuid environment"
HOMEPAGE="http://s0ftpj.org/projects/sud/index.htm"
@@ -14,32 +14,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
+PATCHES=( "${FILESDIR}"/${PN}-1.3-fix-build-system.patch )
+
src_prepare() {
- sed -i -e \
- 's/install-data-hook:$/& install-exec/' \
- -e \
- 's:chmod 500 $(sbindir)/ilogin:chmod 500 $(DESTDIR)$(sbindir)/ilogin:' \
- "${S}"/login/Makefile.in || die "sed failed."
- sed -i -e \
- 's/install-data-hook:$/& install-exec/' \
- -e \
- 's:chmod 555 $(bindir)/suz:chmod 500 $(DESTDIR)$(bindir)/suz:' \
- "${S}"/su/Makefile.in || die "sed failed."
- sed -i -e \
- 's/install-data-hook:$/& install-exec/' \
- -e \
- 's:chmod 500 $(sbindir)/sud:chmod 500 $(DESTDIR)$(sbindir)/sud:' \
- "${S}"/sud/Makefile.in || die "sed failed."
+ default
+ eautoreconf
}
src_configure() {
- append-flags -D_GNU_SOURCE
- default_src_configure
+ append-cppflags -D_GNU_SOURCE
+ default
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog* README NEWS TODO
+ default
+
doman ilogin.1 sud.1 suz.1
insinto /etc
doins miscs/sud.conf*