summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/verynice/files/verynice-1.1-build.patch4
-rw-r--r--app-admin/verynice/verynice-1.1-r2.ebuild4
-rw-r--r--app-admin/verynice/verynice-1.1-r3.ebuild9
3 files changed, 8 insertions, 9 deletions
diff --git a/app-admin/verynice/files/verynice-1.1-build.patch b/app-admin/verynice/files/verynice-1.1-build.patch
index a70202b99300..3782c74a5c05 100644
--- a/app-admin/verynice/files/verynice-1.1-build.patch
+++ b/app-admin/verynice/files/verynice-1.1-build.patch
@@ -5,8 +5,8 @@ Subject: build system
respect flags, add LDFLAGS to linker line
fix install rules
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -15,13 +15,15 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
diff --git a/app-admin/verynice/verynice-1.1-r2.ebuild b/app-admin/verynice/verynice-1.1-r2.ebuild
index d4536a3b895e..e9dc02e399c0 100644
--- a/app-admin/verynice/verynice-1.1-r2.ebuild
+++ b/app-admin/verynice/verynice-1.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-inherit eutils systemd toolchain-funcs
+inherit epatch systemd toolchain-funcs
DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
HOMEPAGE="https://web.archive.org/web/2010033109/http://thermal.cnde.iastate.edu/~sdh4/verynice/"
@@ -17,7 +17,7 @@ IUSE=""
S=${WORKDIR}/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${PN}-1.1-build.patch
}
src_compile() {
diff --git a/app-admin/verynice/verynice-1.1-r3.ebuild b/app-admin/verynice/verynice-1.1-r3.ebuild
index b6334a5e2815..7aba33fc8dc2 100644
--- a/app-admin/verynice/verynice-1.1-r3.ebuild
+++ b/app-admin/verynice/verynice-1.1-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils systemd toolchain-funcs
+inherit systemd toolchain-funcs
DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
HOMEPAGE="https://web.archive.org/web/20130621090315/http://thermal.cnde.iastate.edu/~sdh4/verynice/"
@@ -16,10 +16,9 @@ IUSE=""
S=${WORKDIR}/${PN}
-src_prepare() {
- default
- epatch "${FILESDIR}"/${P}-build.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-build.patch
+)
src_compile() {
tc-export CC