summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/Manifest2
-rw-r--r--app-arch/lbzip2/files/lbzip2-2.3-s_isreg.patch16
-rw-r--r--app-arch/lbzip2/lbzip2-2.3-r1.ebuild38
-rw-r--r--app-arch/lbzip2/lbzip2-2.5.ebuild38
-rw-r--r--app-arch/lbzip2/metadata.xml19
5 files changed, 113 insertions, 0 deletions
diff --git a/app-arch/lbzip2/Manifest b/app-arch/lbzip2/Manifest
new file mode 100644
index 000000000000..75bd4bf69848
--- /dev/null
+++ b/app-arch/lbzip2/Manifest
@@ -0,0 +1,2 @@
+DIST lbzip2-2.3.tar.gz 630226 SHA256 d3110a2b9e19da277dec899f7a3f435cc130a518f6a43094ec4e31ca15f93eaa SHA512 4f694445cc90377bf8dac5046b952ff174db571f390c2d7b0aa001f73c76f3d3f048ff8e7297c2055ed1f7b210174496dc31d6628e1cbeff63146a36a442ad4c WHIRLPOOL 781c9e07eccb633eeb713a9e4f821e0a75102e182d6a6ea4dfba7e33aa96afbfd92fdd5d0e9818ec4c41cf86733fe0396bb42071aad7a47c5e4cdd6426812527
+DIST lbzip2-2.5.tar.gz 651399 SHA256 46c75ee93cc95eedc6005625442b2b8e59a2bef3ba80987d0491f055185650e9 SHA512 76e96cfa75b3ed515b2f891349dffc1403daab2dd0a2a614fa0c811cec6ca25faa395da08ad68a9b6ba4069332c4571f70fb7424f06ef3d800c3082c08d7d3d7 WHIRLPOOL b64e70239d89782499cd59731130258d0432dbd69f84d1bed2adb7f573f706ab635a80bd2e2331231f4aad0c92b51151a0c45f192f4fcea9579fb1eef2fa8708
diff --git a/app-arch/lbzip2/files/lbzip2-2.3-s_isreg.patch b/app-arch/lbzip2/files/lbzip2-2.3-s_isreg.patch
new file mode 100644
index 000000000000..6f4954102f5d
--- /dev/null
+++ b/app-arch/lbzip2/files/lbzip2-2.3-s_isreg.patch
@@ -0,0 +1,16 @@
+ src/main.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/main.c b/src/main.c
+index f030fd5..5f8290e 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -702,7 +702,7 @@ input_init(const struct arg *operand, struct stat *sbuf)
+ return -1;
+ }
+
+- if (OM_REGF == outmode && !S_ISREG(sbuf->st_mode)) {
++ if (!decompress && OM_REGF == outmode && !S_ISREG(sbuf->st_mode)) {
+ warn("skipping \"%s\": not a regular file", operand->val);
+ return -1;
+ }
diff --git a/app-arch/lbzip2/lbzip2-2.3-r1.ebuild b/app-arch/lbzip2/lbzip2-2.3-r1.ebuild
new file mode 100644
index 000000000000..07f82d83a6fe
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="http://archive.lbzip2.org/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug symlink"
+
+RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-s_isreg.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug tracing)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2
+ dosym lbunzip2 /usr/bin/bunzip2
+ fi
+}
diff --git a/app-arch/lbzip2/lbzip2-2.5.ebuild b/app-arch/lbzip2/lbzip2-2.5.ebuild
new file mode 100644
index 000000000000..c6f53ffebbaf
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="http://archive.lbzip2.org/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug symlink"
+
+RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-2.3-s_isreg.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug tracing)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2
+ dosym lbunzip2 /usr/bin/bunzip2
+ fi
+}
diff --git a/app-arch/lbzip2/metadata.xml b/app-arch/lbzip2/metadata.xml
new file mode 100644
index 000000000000..22603f78e326
--- /dev/null
+++ b/app-arch/lbzip2/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>mattst88@gentoo.org</email>
+ <name>Matt Turner</name>
+ </maintainer>
+ <longdescription lang="en">
+ A multi-threaded bzip2/bunzip2 utility that employs multiple threads and an
+ input-bound splitter even when decompressing .bz2 files created by standard
+ bzip2
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kjn/lbzip2</remote-id>
+ </upstream>
+</pkgmetadata>