summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/undms/undms-1.3-r1.ebuild')
-rw-r--r--app-arch/undms/undms-1.3-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-arch/undms/undms-1.3-r1.ebuild b/app-arch/undms/undms-1.3-r1.ebuild
new file mode 100644
index 000000000000..4d27ed1f5662
--- /dev/null
+++ b/app-arch/undms/undms-1.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Decompress Amiga DMS disk images to ADF"
+SRC_URI="ftp://us.aminet.net/pub/aminet/misc/unix/${P}.c.Z ftp://us.aminet.net/pub/aminet/misc/unix/${P}.c.Z.readme"
+HOMEPAGE="ftp://us.aminet.net/pub/aminet/misc/unix/"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${P}.c || die "Compilation failed"
+}
+
+src_install() {
+ dobin undms
+ newdoc "${DISTDIR}"/${P}.c.Z.readme readme
+}