summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/borgbackup')
-rw-r--r--app-backup/borgbackup/Manifest3
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild43
-rw-r--r--app-backup/borgbackup/borgbackup-1.2.1-r2.ebuild47
-rw-r--r--app-backup/borgbackup/borgbackup-1.2.8.ebuild53
-rw-r--r--app-backup/borgbackup/borgbackup-9999.ebuild47
-rw-r--r--app-backup/borgbackup/metadata.xml8
6 files changed, 56 insertions, 145 deletions
diff --git a/app-backup/borgbackup/Manifest b/app-backup/borgbackup/Manifest
index 4a5b06dc03d6..cec374466abc 100644
--- a/app-backup/borgbackup/Manifest
+++ b/app-backup/borgbackup/Manifest
@@ -1,2 +1 @@
-DIST borgbackup-1.1.17.tar.gz 3781411 BLAKE2B 3ceb51f3c2e4ee4e38495ca0bdef2d5c1b30225afe9a3c9987a82f4a1facd4aa203fb21512e655fbbab400bcbd412ff4aefa80242aa21a579e086d38bf3e1078 SHA512 6170680efcca35341031a8fcfd9434d2dca530bb6f7fcabbf452e6af6a8df5a825b4991d342f3c97bd7378d56b9ee86e6118f9281a31ba51235f49818852f4bb
-DIST borgbackup-1.2.1.tar.gz 4017050 BLAKE2B 2841f3c02b6af76aba61064513ebd9039367be868a5f0dad2e10cbf3243236a5d29609bee63b79056f2a553052d3dc415178dbabd5c1e5af9c43111286942869 SHA512 47e95960c9ce7715897834f400ee1a3dcbbbd9aa1e4b69dc93618ade24caf6c046b844c9f3edd10e090795d06bed0136fbd42d6e679f0639f221b83d82545d43
+DIST borgbackup-1.2.8.tar.gz 4369117 BLAKE2B f230274189716e6ecb8f73d10caa13e683e63c9d9f50c5b6235fc666a0f64f3048421e76e5b57626144c37d37d28c4371b368f780f5e32055f62d5ff10954c19 SHA512 9a62e5eec894ebffe928a08c9a0cceebde084f16524d363a3c3be01d908a7eceaea8fa11eac422acc0fdb2534d79d1ee5ec5d9167e1086f334af6a28887616d5
diff --git a/app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild b/app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild
deleted file mode 100644
index f4117d28dc50..000000000000
--- a/app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/llfuse[${PYTHON_USEDEP}]
- dev-libs/openssl:0=
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}
diff --git a/app-backup/borgbackup/borgbackup-1.2.1-r2.ebuild b/app-backup/borgbackup/borgbackup-1.2.1-r2.ebuild
deleted file mode 100644
index 9ac4b1a5217a..000000000000
--- a/app-backup/borgbackup/borgbackup-1.2.1-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-# borgbackup is *very* picky about which msgpack it work with,
-# check setup.py on bumps.
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/pyfuse3[${PYTHON_USEDEP}]
- ~dev-python/msgpack-1.0.4[${PYTHON_USEDEP}]
- dev-libs/openssl:0=
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/cython-0.29.29[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}
diff --git a/app-backup/borgbackup/borgbackup-1.2.8.ebuild b/app-backup/borgbackup/borgbackup-1.2.8.ebuild
new file mode 100644
index 000000000000..ac351d5e5724
--- /dev/null
+++ b/app-backup/borgbackup/borgbackup-1.2.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
+
+# "import file mismatch" when in S, "attempted relative import with no
+# known parent package" when in BUILD_DIR/install/.../borg/testsuite.
+# Needs work.
+RESTRICT="test"
+
+DEPEND="app-arch/lz4
+ app-arch/zstd
+ dev-libs/openssl:0=
+ >=dev-libs/xxhash-0.8.1
+ virtual/acl"
+# borgbackup is *very* picky about which msgpack it work with,
+# check setup.py on bumps.
+RDEPEND="${DEPEND}
+ ~dev-python/msgpack-1.0.8[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyfuse3[${PYTHON_USEDEP}]"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/*
+
+ dobashcomp scripts/shell_completions/bash/borg
+
+ insinto /usr/share/zsh/site-functions
+ doins scripts/shell_completions/zsh/_borg
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins scripts/shell_completions/fish/borg.fish
+}
diff --git a/app-backup/borgbackup/borgbackup-9999.ebuild b/app-backup/borgbackup/borgbackup-9999.ebuild
deleted file mode 100644
index 9ac4b1a5217a..000000000000
--- a/app-backup/borgbackup/borgbackup-9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-# borgbackup is *very* picky about which msgpack it work with,
-# check setup.py on bumps.
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/pyfuse3[${PYTHON_USEDEP}]
- ~dev-python/msgpack-1.0.4[${PYTHON_USEDEP}]
- dev-libs/openssl:0=
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/cython-0.29.29[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}
diff --git a/app-backup/borgbackup/metadata.xml b/app-backup/borgbackup/metadata.xml
index 949760b7e483..17284e4eaf25 100644
--- a/app-backup/borgbackup/metadata.xml
+++ b/app-backup/borgbackup/metadata.xml
@@ -2,12 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
- </maintainer>
- <maintainer type="person">
- <email>slashbeast@gentoo.org</email>
- <name>Piotr Karbowski</name>
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
</maintainer>
<upstream>
<remote-id type="github">borgbackup/borg</remote-id>