summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ltp')
-rw-r--r--app-benchmarks/ltp/Manifest4
-rw-r--r--app-benchmarks/ltp/files/runltp-path.patch199
-rw-r--r--app-benchmarks/ltp/ltp-20130503.ebuild82
-rw-r--r--app-benchmarks/ltp/ltp-20140828.ebuild84
-rw-r--r--app-benchmarks/ltp/ltp-20150119.ebuild84
-rw-r--r--app-benchmarks/ltp/ltp-20150420.ebuild84
-rw-r--r--app-benchmarks/ltp/metadata.xml25
7 files changed, 562 insertions, 0 deletions
diff --git a/app-benchmarks/ltp/Manifest b/app-benchmarks/ltp/Manifest
new file mode 100644
index 000000000000..28154314c1d2
--- /dev/null
+++ b/app-benchmarks/ltp/Manifest
@@ -0,0 +1,4 @@
+DIST ltp-20130503.tar.bz2 3819156 SHA256 afdb1479e73d4da7f0d4d5d3fe1570bc5fc96e3317d4a5c10c59c046d3dfa4a0 SHA512 efe7c3e5ffba51b03f01ee66d940d400f4f007dcc42ca45f9597fc1a325950ee14f663762280d63004080c717f16f39bc0d53b5905290470952ef5af3725f089 WHIRLPOOL 924cdc730e85d66d8d7655461e0a59a563b7a9039133b4e991a115d20453f46dda158ac82f474fc8d9ea720a4d03fc67d4d55c231c11d35dc3bfdc5b10a7258b
+DIST ltp-20140828.tar.bz2 3914567 SHA256 046069523f04d8be8689c9e3f7f475e11d21c3d97506189a4a5e23c80b77492a SHA512 4963184624c8d6686dd9bda171bb2917a16b782f575e73ac18641ee66070b72f34c1e222936c52e529038854bd8d67d05b286d5f1319fd73098823ddbfe29545 WHIRLPOOL 32ec59ccd3cea3e4cfe8f73c4eb2bf8f8a86fd2fd0f82df8afabe8b62fd8e92fc9d3dbde52875d2be241542a6e3608ea5507d5f6495b11c92bcda475f6a69302
+DIST ltp-20150119.tar.bz2 3920104 SHA256 e0433cb184c57bf4e5493bfbceef3e9ee51a1a9778990fe4e74e62b17b94232f SHA512 ab7a76d700279895442a35507c58d2d1d2e727f3f7dfec067109a8f04bd23d18d0466c20bb1a37af8691bab9260353431e642b493a218b4317357ba8f6aace3a WHIRLPOOL 69c3e79ca8ceb68197ac8905fa7251a31207465d3992c997b4feb4bbd175657b71f667960aed5658aa5e477edf8388ded34a75476d827fb0fa337f4210975f54
+DIST ltp-20150420.tar.bz2 3893685 SHA256 483a6896b526a2972bc76598c8f1c17f7bc875df2dcb239ad5433a6d5977b79d SHA512 ffdf86a0bd63bb08f59c09e41ccf9b5aa2ac1d407fe39fa37dc3874b9cd60fcea9bf8bbe9481bdf1be4f08973e36b35027463db7da686abaf6233c82865f8215 WHIRLPOOL dd78a04c9084894277f56461992fbe118f20fa8b93b0d5452962eb803d71c611c90f3de2187bdc4fbe80b1078b9602f3e8044e0e6312672020c35a998f492edf
diff --git a/app-benchmarks/ltp/files/runltp-path.patch b/app-benchmarks/ltp/files/runltp-path.patch
new file mode 100644
index 000000000000..5d8d55b886f4
--- /dev/null
+++ b/app-benchmarks/ltp/files/runltp-path.patch
@@ -0,0 +1,199 @@
+Index: ltp-full-20120903/runltp
+===================================================================
+--- ltp-full-20120903.orig/runltp
++++ ltp-full-20120903/runltp
+@@ -76,7 +76,7 @@ setup()
+ echo "FATAL: unable to change directory to $(dirname $0)"
+ exit 1
+ }
+- export LTPROOT=${PWD}
++ export LTPROOT=/usr/libexec/ltp
+ export TMPBASE="/tmp"
+ export PATH="${PATH}:${LTPROOT}/testcases/bin"
+
+@@ -230,7 +230,7 @@ main()
+ /*)
+ FAILCMDFILE="-C $OPTARG" ;;
+ *)
+- FAILCMDFILE="-C $LTPROOT/output/$OPTARG"
++ FAILCMDFILE="-C $TMPBASE/output/$OPTARG"
+ ALT_DIR_OUT=1 ;;
+ esac ;;
+
+@@ -298,7 +298,7 @@ main()
+ /*)
+ HTMLFILE="$OPTARG";;
+ *)
+- HTMLFILE="$LTPROOT/output/$OPTARG";;
++ HTMLFILE="$TMPBASE/output/$OPTARG";;
+ esac
+ ALT_DIR_OUT=1
+ ALT_HTML_OUT=1;;
+@@ -319,7 +319,7 @@ main()
+ /*)
+ DMESG_DIR="$OPTARG-dmesg-output-`echo $$-``date +%X | tr -d ' '`";;
+ *)
+- DMESG_DIR="$LTPROOT/output/$OPTARG-dmesg-output-`echo $$-``date +%X | tr -d ' '`";;
++ DMESG_DIR="$TMPBASE/output/$OPTARG-dmesg-output-`echo $$-``date +%X | tr -d ' '`";;
+ esac
+ mkdir -p $DMESG_DIR
+ ALT_DMESG_OUT=1;;
+@@ -329,7 +329,7 @@ main()
+ /*)
+ LOGFILE="-l $OPTARG" ;;
+ *)
+- LOGFILE="-l $LTPROOT/results/$OPTARG"
++ LOGFILE="-l $TMPBASE/results/$OPTARG"
+ ALT_DIR_RES=1 ;;
+ esac ;;
+
+@@ -384,7 +384,7 @@ main()
+ /*)
+ OUTPUTFILE="-o $OPTARG";;
+ *)
+- OUTPUTFILE="-o $LTPROOT/output/$OPTARG"
++ OUTPUTFILE="-o $TMPBASE/output/$OPTARG"
+ ALT_DIR_OUT=1 ;;
+ esac ;;
+
+@@ -431,7 +431,7 @@ main()
+ ## It would be nice to create a default log file even if the user has not mentioned
+ if [ ! "$LOGFILE" ]; then ## User has not mentioned about Log File name
+ LOGFILE_NAME=$DEFAULT_FILE_NAME_GENERATION_TIME
+- LOGFILE="-l $LTPROOT/results/LTP_RUN_ON-$LOGFILE_NAME.log"
++ LOGFILE="-l $TMPBASE/results/LTP_RUN_ON-$LOGFILE_NAME.log"
+ ALT_DIR_RES=1
+ PRETTY_PRT=" -p "
+ fi
+@@ -443,14 +443,14 @@ main()
+ if [ ! "$OUTPUTFILE" ]; then ## User has not mentioned about Output File name either
+ if [ ! "$LOGFILE" ]; then ## User has not mentioned about Log File name either
+ FAILED_FILE_NAME=$DEFAULT_FILE_NAME_GENERATION_TIME
+- FAILCMDFILE="-C $LTPROOT/output/LTP_RUN_ON-$FAILED_FILE_NAME.failed"
++ FAILCMDFILE="-C $TMPBASE/output/LTP_RUN_ON-$FAILED_FILE_NAME.failed"
+ else ## User Fortunately wanted a log file,
+ FAILED_FILE_NAME=`basename $LOGFILE_NAME` ## Extract log file name and use it to construct Failed file name
+- FAILCMDFILE="-C $LTPROOT/output/LTP_RUN_ON-$FAILED_FILE_NAME.failed"
++ FAILCMDFILE="-C $TMPBASE/output/LTP_RUN_ON-$FAILED_FILE_NAME.failed"
+ fi
+ else ## User Fortunately wanted a Output file
+ FAILED_FILE_NAME=`basename $OUTPUTFILE_NAME` ## Extract output file name and use it to construct Failed file name
+- FAILCMDFILE="-C $LTPROOT/output/LTP_RUN_ON-$FAILED_FILE_NAME.failed"
++ FAILCMDFILE="-C $TMPBASE/output/LTP_RUN_ON-$FAILED_FILE_NAME.failed"
+ fi
+ fi
+
+@@ -459,11 +459,11 @@ main()
+ ## which the HTML parser will require
+ if [ ! "$OUTPUTFILE" ]; then ## User has not mentioned about the Outputfile name, then we need to definitely generate one
+ OUTPUTFILE_NAME=$DEFAULT_FILE_NAME_GENERATION_TIME
+- OUTPUTFILE="-o $LTPROOT/output/LTP_RUN_ON-$OUTPUTFILE_NAME.output"
++ OUTPUTFILE="-o $TMPBASE/output/LTP_RUN_ON-$OUTPUTFILE_NAME.output"
+ ALT_DIR_OUT=1
+ if [ ! "$HTMLFILE" ] ; then ## User has not mentioned HTML File name, We need to create one
+ HTMLFILE_NAME=`basename $OUTPUTFILE_NAME`
+- HTMLFILE="$LTPROOT/output/$HTMLFILE_NAME.html"
++ HTMLFILE="$TMPBASE/output/$HTMLFILE_NAME.html"
+ fi
+ fi
+ fi
+@@ -471,12 +471,12 @@ main()
+ # If we need, create the output directory
+ [ "$ALT_DIR_OUT" -eq 1 ] && \
+ {
+- [ ! -d $LTPROOT/output ] && \
++ [ ! -d $TMPBASE/output ] && \
+ {
+- echo "INFO: creating $LTPROOT/output directory"
+- mkdir -p $LTPROOT/output || \
++ echo "INFO: creating $TMPBASE/output directory"
++ mkdir -p $TMPBASE/output || \
+ {
+- echo "ERROR: failed to create $LTPROOT/output"
++ echo "ERROR: failed to create $TMPBASE/output"
+ exit 1
+ }
+ }
+@@ -484,12 +484,12 @@ main()
+ # If we need, create the results directory
+ [ "$ALT_DIR_RES" -eq 1 ] && \
+ {
+- echo "INFO: creating $LTPROOT/results directory"
+- [ ! -d $LTPROOT/results ] && \
++ echo "INFO: creating $TMPBASE/results directory"
++ [ ! -d $TMPBASE/results ] && \
+ {
+- mkdir -p $LTPROOT/results || \
++ mkdir -p $TMPBASE/results || \
+ {
+- echo "ERROR: failed to create $LTPROOT/results"
++ echo "ERROR: failed to create $TMPBASE/results"
+ exit 1
+ }
+ }
+@@ -867,8 +867,8 @@ main()
+ export TEST_START_TIME=$test_start_time
+ export TEST_END_TIME=$(date)
+ OUTPUT_DIRECTORY=`echo $OUTPUTFILE | cut -c4-`
+- LOGS_DIRECTORY="$LTPROOT/results"
+- export TEST_OUTPUT_DIRECTORY="$LTPROOT/output"
++ LOGS_DIRECTORY="$TMPBASE/results"
++ export TEST_OUTPUT_DIRECTORY="$TMPBASE/output"
+ export TEST_LOGS_DIRECTORY=$LOGS_DIRECTORY
+ echo "Generating HTML Output.....!!"
+ ( perl $LTPROOT/bin/genhtml.pl $LTPROOT/bin/html_report_header.txt test_start test_end test_output execution_status $OUTPUT_DIRECTORY > $HTMLFILE; )
+@@ -884,37 +884,37 @@ main()
+ else
+ TAR_FILE_NAME=LTP_RUN_$version_date$DEFAULT_FILE_NAME_GENERATION_TIME.tar
+ if [ "$HTMLFILE_NAME" ] ; then ## HTML file Exists
+- if [ "$ALT_HTML_OUT" -ne 1 ] ; then ## The HTML file path is absolute and not $LTPROOT/output
+- mkdir -p $LTPROOT/output ## We need to create this Directory
+- cp $HTMLFILE_NAME $LTPROOT/output/
++ if [ "$ALT_HTML_OUT" -ne 1 ] ; then ## The HTML file path is absolute and not $TMPBASE/output
++ mkdir -p $TMPBASE/output ## We need to create this Directory
++ cp $HTMLFILE_NAME $TMPBASE/output/
+ fi
+ fi
+ if [ "$OUTPUTFILE_NAME" ] ; then ## Output file exists
+- if [ "$ALT_DIR_OUT" -ne 1 ] ; then ## The Output file path is absolute and not $LTPROOT/output
+- mkdir -p $LTPROOT/output ## We need to create this Directory
+- cp $OUTPUTFILE_NAME $LTPROOT/output/
++ if [ "$ALT_DIR_OUT" -ne 1 ] ; then ## The Output file path is absolute and not $TMPBASE/output
++ mkdir -p $TMPBASE/output ## We need to create this Directory
++ cp $OUTPUTFILE_NAME $TMPBASE/output/
+ fi
+ fi
+ if [ "$LOGFILE_NAME" ] ; then ## Log file exists
+- if [ "$ALT_DIR_RES" -ne 1 ] ; then ## The Log file path is absolute and not $LTPROOT/results
+- mkdir -p $LTPROOT/results ## We need to create this Directory
+- cp $LOGFILE_NAME $LTPROOT/results/
++ if [ "$ALT_DIR_RES" -ne 1 ] ; then ## The Log file path is absolute and not $TMPBASE/results
++ mkdir -p $TMPBASE/results ## We need to create this Directory
++ cp $LOGFILE_NAME $TMPBASE/results/
+ fi
+ fi
+- if [ -d $LTPROOT/output ] ; then
+- tar -cf ./$TAR_FILE_NAME $LTPROOT/output
++ if [ -d $TMPBASE/output ] ; then
++ tar -cf ./$TAR_FILE_NAME $TMPBASE/output
+ if [ $? -eq 0 ]; then
+- echo "Created TAR File: ./$TAR_FILE_NAME successfully, added $LTPROOT/output"
++ echo "Created TAR File: ./$TAR_FILE_NAME successfully, added $TMPBASE/output"
+ else
+- echo "Cannot Create TAR File: ./$TAR_FILE_NAME for adding $LTPROOT/output"
++ echo "Cannot Create TAR File: ./$TAR_FILE_NAME for adding $TMPBASE/output"
+ fi
+ fi
+- if [ -d $LTPROOT/results ] ; then
+- tar -uf ./$TAR_FILE_NAME $LTPROOT/results
++ if [ -d $TMPBASE/results ] ; then
++ tar -uf ./$TAR_FILE_NAME $TMPBASE/results
+ if [ $? -eq 0 ]; then
+- echo "Updated TAR File: ./$TAR_FILE_NAME successfully, added $LTPROOT/results"
++ echo "Updated TAR File: ./$TAR_FILE_NAME successfully, added $TMPBASE/results"
+ else
+- echo "Cannot Update TAR File: ./$TAR_FILE_NAME for adding $LTPROOT/results"
++ echo "Cannot Update TAR File: ./$TAR_FILE_NAME for adding $TMPBASE/results"
+ fi
+ fi
+ if [ -e $LTPROOT/nohup.out ] ; then ## If User would have Chosen nohup to do ltprun
diff --git a/app-benchmarks/ltp/ltp-20130503.ebuild b/app-benchmarks/ltp/ltp-20130503.ebuild
new file mode 100644
index 000000000000..82aa09b65a15
--- /dev/null
+++ b/app-benchmarks/ltp/ltp-20130503.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils readme.gentoo
+
+MY_PN="${PN}-full"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A testsuite for the linux kernel"
+HOMEPAGE="http://ltp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ltp/LTP%20Source/${P}/${MY_P}.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="expect perl pm open-posix python rt"
+
+DEPEND="expect? ( dev-tcltk/expect )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ # Don't create groups
+ export CREATE=0
+
+ DOC_CONTENTS="LTP requires root access to run the tests.
+ The LTP root directory is located in /opt/${PN}.
+ For more information please read the ltp-howto located in
+ /usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ # regenerate
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # FIXME: improve me
+ local myconf=
+ use open-posix && myconf+="--with-open-posix-testsuite "
+ use pm && mytconf+="--with-power-management-testsuite "
+ use rt && myconf+="--with-realtime-testsuite "
+ use perl && myconf+="--with-perl "
+ use python && myconf+="--with-python "
+ use expect && myconf+="--with-expect "
+
+ # Better put it into /opt/${PN} as everything needs to
+ # be under the same directory..
+
+ econf --prefix=/opt/${PN} ${myconf}
+}
+
+src_compile() {
+ # Posix testsuite does not seem to build with -j>1
+ # Is this maintained anymore?
+ if use open-posix; then
+ export MAKEOPTS="-j1"
+ fi
+ emake
+}
+
+src_install() {
+ default
+ dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
+ # install docs
+ dodoc doc/MaintNotes
+ for txt in doc/*.txt; do
+ dodoc ${txt}
+ done
+ dodoc -r doc/examples doc/testcases
+ dohtml -r doc/automation-*.html
+ doman doc/man1/*.1
+ doman doc/man3/*.3
+ readme.gentoo_create_doc
+}
diff --git a/app-benchmarks/ltp/ltp-20140828.ebuild b/app-benchmarks/ltp/ltp-20140828.ebuild
new file mode 100644
index 000000000000..921376d3fb58
--- /dev/null
+++ b/app-benchmarks/ltp/ltp-20140828.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils readme.gentoo
+
+MY_PN="${PN}-full"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A testsuite for the linux kernel"
+HOMEPAGE="http://ltp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ltp/LTP%20Source/${P}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="expect perl pm open-posix python rt"
+
+DEPEND="expect? ( dev-tcltk/expect )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ # Don't create groups
+ export CREATE=0
+
+ DOC_CONTENTS="LTP requires root access to run the tests.
+ The LTP root directory is located in /opt/${PN}.
+ For more information please read the ltp-howto located in
+ /usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ # regenerate
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # FIXME: improve me
+ local myconf=
+ use open-posix && myconf+="--with-open-posix-testsuite "
+ use pm && mytconf+="--with-power-management-testsuite "
+ use rt && myconf+="--with-realtime-testsuite "
+ use perl && myconf+="--with-perl "
+ use python && myconf+="--with-python "
+ use expect && myconf+="--with-expect "
+ # Prevent any kernel stuff for now as it leads to sandbox violations
+ myconf+="--without-modules --with-linux-dir=/dev/null"
+
+ # Better put it into /opt/${PN} as everything needs to
+ # be under the same directory..
+
+ econf --prefix=/opt/${PN} ${myconf}
+}
+
+src_compile() {
+ # Posix testsuite does not seem to build with -j>1
+ # Is this maintained anymore?
+ if use open-posix; then
+ export MAKEOPTS="-j1"
+ fi
+ emake
+}
+
+src_install() {
+ default
+ dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
+ # install docs
+ dodoc doc/MaintNotes
+ for txt in doc/*.txt; do
+ dodoc ${txt}
+ done
+ dodoc -r doc/testcases
+ dohtml -r doc/automation-*.html
+ doman doc/man1/*.1
+ doman doc/man3/*.3
+ readme.gentoo_create_doc
+}
diff --git a/app-benchmarks/ltp/ltp-20150119.ebuild b/app-benchmarks/ltp/ltp-20150119.ebuild
new file mode 100644
index 000000000000..5ef070c52998
--- /dev/null
+++ b/app-benchmarks/ltp/ltp-20150119.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils readme.gentoo
+
+MY_PN="${PN}-full"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A testsuite for the linux kernel"
+HOMEPAGE="http://ltp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ltp/LTP%20Source/${P}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="expect perl pm open-posix python rt"
+
+DEPEND="expect? ( dev-tcltk/expect )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ # Don't create groups
+ export CREATE=0
+
+ DOC_CONTENTS="LTP requires root access to run the tests.
+ The LTP root directory is located in /opt/${PN}.
+ For more information please read the ltp-howto located in
+ /usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ # regenerate
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # FIXME: improve me
+ local myconf=
+ use open-posix && myconf+="--with-open-posix-testsuite "
+ use pm && mytconf+="--with-power-management-testsuite "
+ use rt && myconf+="--with-realtime-testsuite "
+ use perl && myconf+="--with-perl "
+ use python && myconf+="--with-python "
+ use expect && myconf+="--with-expect "
+ # Prevent any kernel stuff for now as it leads to sandbox violations
+ myconf+="--without-modules --with-linux-dir=/dev/null"
+
+ # Better put it into /opt/${PN} as everything needs to
+ # be under the same directory..
+
+ econf --prefix=/opt/${PN} ${myconf}
+}
+
+src_compile() {
+ # Posix testsuite does not seem to build with -j>1
+ # Is this maintained anymore?
+ if use open-posix; then
+ export MAKEOPTS="-j1"
+ fi
+ emake
+}
+
+src_install() {
+ default
+ dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
+ # install docs
+ dodoc doc/MaintNotes
+ for txt in doc/*.txt; do
+ dodoc ${txt}
+ done
+ dodoc -r doc/testcases
+ dohtml -r doc/automation-*.html
+ doman doc/man1/*.1
+ doman doc/man3/*.3
+ readme.gentoo_create_doc
+}
diff --git a/app-benchmarks/ltp/ltp-20150420.ebuild b/app-benchmarks/ltp/ltp-20150420.ebuild
new file mode 100644
index 000000000000..5ef070c52998
--- /dev/null
+++ b/app-benchmarks/ltp/ltp-20150420.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils readme.gentoo
+
+MY_PN="${PN}-full"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A testsuite for the linux kernel"
+HOMEPAGE="http://ltp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ltp/LTP%20Source/${P}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="expect perl pm open-posix python rt"
+
+DEPEND="expect? ( dev-tcltk/expect )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ # Don't create groups
+ export CREATE=0
+
+ DOC_CONTENTS="LTP requires root access to run the tests.
+ The LTP root directory is located in /opt/${PN}.
+ For more information please read the ltp-howto located in
+ /usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ # regenerate
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # FIXME: improve me
+ local myconf=
+ use open-posix && myconf+="--with-open-posix-testsuite "
+ use pm && mytconf+="--with-power-management-testsuite "
+ use rt && myconf+="--with-realtime-testsuite "
+ use perl && myconf+="--with-perl "
+ use python && myconf+="--with-python "
+ use expect && myconf+="--with-expect "
+ # Prevent any kernel stuff for now as it leads to sandbox violations
+ myconf+="--without-modules --with-linux-dir=/dev/null"
+
+ # Better put it into /opt/${PN} as everything needs to
+ # be under the same directory..
+
+ econf --prefix=/opt/${PN} ${myconf}
+}
+
+src_compile() {
+ # Posix testsuite does not seem to build with -j>1
+ # Is this maintained anymore?
+ if use open-posix; then
+ export MAKEOPTS="-j1"
+ fi
+ emake
+}
+
+src_install() {
+ default
+ dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
+ # install docs
+ dodoc doc/MaintNotes
+ for txt in doc/*.txt; do
+ dodoc ${txt}
+ done
+ dodoc -r doc/testcases
+ dohtml -r doc/automation-*.html
+ doman doc/man1/*.1
+ doman doc/man3/*.3
+ readme.gentoo_create_doc
+}
diff --git a/app-benchmarks/ltp/metadata.xml b/app-benchmarks/ltp/metadata.xml
new file mode 100644
index 000000000000..803b59bff20c
--- /dev/null
+++ b/app-benchmarks/ltp/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <use>
+ <flag name="open-posix">Build and install the POSIX testsuite</flag>
+ <flag name="pm">Build and install the power management testsuite</flag>
+ <flag name="expect">Build against the expect library for interactive testing</flag>
+ <flag name="rt">Build and install the realtime testsuite</flag>
+ </use>
+ <longdescription>
+ The Linux Test Project is a joint project started by SGI and maintained by
+ IBM, that has a goal to deliver test suites to the open source community
+ that validate the reliability, robustness, and stability of Linux. The LTP
+ testsuite contains a collection of tools for testing the Linux kernel and
+ related features.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ltp</remote-id>
+ </upstream>
+</pkgmetadata>