summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.11.6_beta.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index ca47fbdbee30..ccda40db65ce 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1,2 +1,3 @@
DIST moolticute-0.10.0_beta.tar.gz 4945663 BLAKE2B 371ab382239d635251b3921cbae24ee8f0ccefdd2ca2a102e73ecf2eccdef5a86f1613d9cc051871b37ebe9936ffb5f95719f7e3c36c4d7fdc58a18ba9948b73 SHA512 febb828cc179cbbc40684b7c382babfe998d8e14c59358d985658dabc0c414de7b5bec3187336459b286fb85b79f8d781254c7dc55ecd6519fc4ea50952af9b4
DIST moolticute-0.11.4_beta.tar.gz 5278216 BLAKE2B 7d78549e9ea384669ea2fcea3f543e543ece87b9ce016fbb8675d0ea9065957c0d10bd6048a43c37715de3d1638fa75c518640feca22702713c7c7ab6c9e2ea1 SHA512 4c832b286784c4e8fbfc2eea498e4b7c57377ba745ba226c88001a3ab564d6e7c719dcdb849a409e367eaebc43a8b4c6e756b8a3e90a722f48554df4822e7a19
+DIST moolticute-0.11.6_beta.tar.gz 5279167 BLAKE2B 4b93dbb038f75502907729398e7315397d5fd46fd7ee57214d5ea2f8dfdddd6c6d1e02242384ec8ca3a67a94711b7b3b68f28e4bb63cb24b224fcdfd75de1435 SHA512 5caf3ad6063da6d1761af37e52561b5834753abbc433e221b874788dd5c98782af8b4e723a78b2e849b8fe7cd0378e9304e5e93ac47e76d547dfc6b8ebe3c92a
diff --git a/app-crypt/moolticute/moolticute-0.11.6_beta.ebuild b/app-crypt/moolticute/moolticute-0.11.6_beta.ebuild
new file mode 100644
index 000000000000..b5153ad45a3e
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.11.6_beta.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ >=dev-qt/qtcore-5.6:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}