summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/acme-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 469f2ebb3d1a..ce2e17f3d795 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -28,11 +28,16 @@ RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+python_prepare_all() {
+ sed -i -e "/'argparse',/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
nosetests -w ${PN} || die
}