summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/zeal/Manifest1
-rw-r--r--app-doc/zeal/metadata.xml17
-rw-r--r--app-doc/zeal/zeal-0.1.1.ebuild55
3 files changed, 73 insertions, 0 deletions
diff --git a/app-doc/zeal/Manifest b/app-doc/zeal/Manifest
new file mode 100644
index 000000000000..34712463f8b6
--- /dev/null
+++ b/app-doc/zeal/Manifest
@@ -0,0 +1 @@
+DIST zeal-0.1.1.tar.gz 914203 SHA256 f4e959f9bc66a6e350ee8a33d34695379633432d103db9776c0c7a76cbc5a9d6 SHA512 388f3fdeb373d0061e72395d0e11a01cbe2365149a697cc3291b76f76f56e211afa96e6e31660ad16c88b67d62218f3d3b7a762102c0df45280bf85e2bfdfe8b WHIRLPOOL 5a5b2ecc49b724f642cb1e658d742b894620cf33f3086d5984033d9aaa7606726ff54522d2f78f1c06b555a59875e0595b2402d045728f474dd7b41cd42be3a5
diff --git a/app-doc/zeal/metadata.xml b/app-doc/zeal/metadata.xml
new file mode 100644
index 000000000000..8a160497c50b
--- /dev/null
+++ b/app-doc/zeal/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>ahvenas@gmail.com</email>
+ <name>Henrik Pihl</name>
+</maintainer>
+<longdescription>
+Zeal is a simple offline API documentation browser inspired by Dash (OS X app), available for Linux and Windows.
+Quickly search documentation using Alt+Space (or customised) hotkey to display Zeal from any place in your workspace.
+- Search in multiple sets of documentation at once.
+- Don't be dependent on your internet connection.
+- Integrate Zeal with Emacs, Sublime Text, or Vim.
+All documentation available for Dash is also available for Zeal.
+You can also generate your own docsets using the same format Dash uses.
+</longdescription>
+</pkgmetadata>
diff --git a/app-doc/zeal/zeal-0.1.1.ebuild b/app-doc/zeal/zeal-0.1.1.ebuild
new file mode 100644
index 000000000000..5f1da638c31a
--- /dev/null
+++ b/app-doc/zeal/zeal-0.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils gnome2-utils fdo-mime
+
+DESCRIPTION="Offline documentation browser inspired by Dash"
+HOMEPAGE="https://zealdocs.org/"
+SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${P}/src"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-arch/libarchive
+ >=dev-qt/qtconcurrent-5.2.0:5
+ >=dev-qt/qtgui-5.4.0:5
+ >=dev-qt/qtnetwork-5.4.0
+ >=dev-qt/qtsql-5.4.0:5
+ >=dev-qt/qtwebkit-5.4.0:5
+ >=dev-qt/qtwidgets-5.4.0:5
+ >=x11-libs/xcb-util-keysyms-0.3.9
+"
+RDEPEND="
+ ${DEPEND}
+ x11-themes/hicolor-icon-theme
+"
+
+src_configure() {
+ eqmake5
+ PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}