summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/Manifest2
-rw-r--r--app-editors/fte/files/fte26
-rw-r--r--app-editors/fte/fte-20110708-r1.ebuild119
-rw-r--r--app-editors/fte/metadata.xml8
4 files changed, 0 insertions, 155 deletions
diff --git a/app-editors/fte/Manifest b/app-editors/fte/Manifest
deleted file mode 100644
index ff4fbf95bc65..000000000000
--- a/app-editors/fte/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST fte-20110708-common.zip 200007 BLAKE2B ce1ac0f2bd68b2bb7ef1d96a46bd9a481cd46f5cde00607c64f752d5e87f6edefd8a92c8210e1ac7629ef8bc5720a8a2d75bd61f292f344e211b88a2462989fa SHA512 0bb59a5b6b4a5ef6c1234dadd8922cd50a13ad1f0c06d6046b74a95592ad55f720b43bbc78a42cab63dfc68c5e073d44d5179bd6ed72f346563f43f3c5c146f1
-DIST fte-20110708-src.zip 504199 BLAKE2B 42bb3cc4ae9be4b64c0b161488d91d4a260a2e6a1574fccb0fc652359e34f7b6b881f170dfd85a8954f2b2fdbe4fecaaf2fc68cd5244f185dde36fe1a694004e SHA512 2d59fadcdd988ee85b87425c343341e1b768a7e9ef838c5f8a1f22c4adc5bf2cc37d547f36354ca1740bce07b33d5ae93d14e24001b9dbd3b1b267986564a089
diff --git a/app-editors/fte/files/fte b/app-editors/fte/files/fte
deleted file mode 100644
index 2e4621b92a62..000000000000
--- a/app-editors/fte/files/fte
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-#
-# simple wrapper shell script which selects appropriate fte executable
-#
-
-if [ -n "$DISPLAY" ]; then
- if which xfte >/dev/null; then
- exec xfte "$@"
- elif which sfte >/dev/null; then
- exec sfte "$@"
- elif which vfte >/dev/null; then
- echo "Only Console version installed!"
- fi
-else
- if [ "$TERM" = linux ] && which vfte >/dev/null; then
- exec vfte "$@"
- elif which sfte >/dev/null; then
- exec sfte "$@"
- elif which xfte >/dev/null; then
- echo "Only X-Window version installed!"
- fi
-
-fi
-
-echo "No binary executable from the FTE family has been found!"
-echo "Please install one of them."
diff --git a/app-editors/fte/fte-20110708-r1.ebuild b/app-editors/fte/fte-20110708-r1.ebuild
deleted file mode 100644
index 5234cee9c559..000000000000
--- a/app-editors/fte/fte-20110708-r1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs vcs-clean
-
-DESCRIPTION="Lightweight text-mode editor"
-HOMEPAGE="http://fte.sourceforge.net"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}-src.zip
- mirror://sourceforge/${PN}/${P}-common.zip"
-
-LICENSE="|| ( GPL-2 Artistic )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ppc ~riscv -sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="gpm slang X"
-
-S="${WORKDIR}/${PN}"
-
-RDEPEND="
- sys-libs/ncurses:0=
- X? (
- x11-libs/libXdmcp
- x11-libs/libXau
- x11-libs/libX11
- x11-libs/libXpm
- )
- gpm? ( >=sys-libs/gpm-1.20 )"
-DEPEND="${RDEPEND}
- slang? ( >=sys-libs/slang-2.1.3 )
- app-arch/unzip"
-
-HTML_DOCS=( doc/. )
-
-set_targets() {
- export TARGETS=""
- use slang && TARGETS="${TARGETS} s${PN}"
- use X && TARGETS="${TARGETS} x${PN}"
-
- [[ ${CHOST} == *-linux-gnu* ]] \
- && TARGETS="${TARGETS} v${PN}" \
- || TARGETS="${TARGETS} n${PN}"
-}
-
-src_prepare() {
- default
-
- if [[ -e "${EPREFIX}"/usr/include/linux/keyboard.h ]]; then
- sed "${EPREFIX}"/usr/include/linux/keyboard.h \
- -e '/wait.h/d' > src/hacked_keyboard.h || die
- fi
-
- sed \
- -e "s:<linux/keyboard.h>:\"hacked_keyboard.h\":" \
- -i src/con_linux.cpp || die "sed keyboard"
- sed \
- -e 's:^OPTIMIZE:#&:g' \
- -e '/^LDFLAGS/s:=:+=:g' \
- -e 's:= g++:= $(CXX):g' \
- -i src/${PN}-unix.mak || die "sed CFLAGS, LDFLAGS, CC"
- ecvs_clean
-}
-
-src_configure() {
- set_targets
- sed \
- -e "s:@targets@:${TARGETS}:" \
- -e '/^XINCDIR =/c\XINCDIR =' \
- -e '/^XLIBDIR =/c\XLIBDIR = -lstdc++' \
- -e '/^SINCDIR =/c\SINCDIR = -I'"${EPREFIX}"'/usr/include/slang' \
- -i src/${PN}-unix.mak || die "sed targets"
-
- if ! use gpm; then
- sed \
- -e "s:#define USE_GPM://#define USE_GPM:" \
- -i src/con_linux.cpp || die "sed USE_GPM"
- sed \
- -e "s:-lgpm::" \
- -i src/fte-unix.mak || die "sed -lgpm"
- fi
-}
-
-src_compile() {
- local os="-DLINUX" # by now the default in makefile
- [[ ${CHOST} == *-interix* ]] && os=
-
- DEFFLAGS="PREFIX='${EPREFIX}'/usr CONFIGDIR='${EPREFIX}'/usr/share/${PN} \
- DEFAULT_FTE_CONFIG=../config/main.${PN} UOS=${os}"
-
- set_targets
- emake CXX="$(tc-getCXX)" OPTIMIZE="${CXXFLAGS}" "${DEFFLAGS}" TARGETS="${TARGETS}" all
-}
-
-src_install() {
- keepdir /etc/${PN}
- into /usr
-
- set_targets
-
- local i files="${TARGETS} c${PN}"
- for i in ${files}; do
- dobin src/${i}
- done
-
- dobin "${FILESDIR}/${PN}"
-
- einstalldocs
-
- insinto /usr/share/${PN}
- doins -r config/.
-}
-
-pkg_postinst() {
- ebegin "Compiling configuration"
- cd "${EPREFIX}"/usr/share/${PN} || die "missing configuration dir"
- "${EPREFIX}"/usr/bin/c${PN} main.${PN} "${EPREFIX}"/etc/${PN}/system.${PN}rc || die
- eend $?
-}
diff --git a/app-editors/fte/metadata.xml b/app-editors/fte/metadata.xml
deleted file mode 100644
index 1a3b29f46396..000000000000
--- a/app-editors/fte/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">fte</remote-id>
- </upstream>
-</pkgmetadata>