summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/joe-4.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-editors/joe/joe-4.3.ebuild b/app-editors/joe/joe-4.3.ebuild
index 7025172d096c..c1aed9e73d33 100644
--- a/app-editors/joe/joe-4.3.ebuild
+++ b/app-editors/joe/joe-4.3.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="xterm"
-DEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND=">=sys-libs/ncurses-5.2-r2:0="
RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
@@ -22,9 +22,9 @@ src_prepare() {
default
# Enable xterm mouse support in the rc files
if use xterm; then
- cd "${S}"/rc
+ cd "${S}"/rc || die
for i in *rc*.in; do
- sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die
done
fi
}