summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mg/mg-20110905-r1.ebuild')
-rw-r--r--app-editors/mg/mg-20110905-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/mg/mg-20110905-r1.ebuild b/app-editors/mg/mg-20110905-r1.ebuild
new file mode 100644
index 000000000000..46d813d5ed40
--- /dev/null
+++ b/app-editors/mg/mg-20110905-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="http://homepage.boetes.org/software/mg/"
+SRC_URI="http://homepage.boetes.org/software/mg/${P}.tar.gz"
+
+LICENSE="public-domain ISC BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="livecd"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # remove OpenBSD specific easter egg
+ sed -i -e 's/theo\.o//' Makefile.in || die
+ sed -i -e '/theo_init/d' main.c || die
+}
+
+src_configure() {
+ # econf won't work, as this script does not accept any parameters
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ einstall
+ dodoc README tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}