summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/wxhexeditor/wxhexeditor-0.20.ebuild')
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.20.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild
new file mode 100644
index 000000000000..606be30dc07d
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+WX_GTK_VER="2.8"
+
+inherit eutils toolchain-funcs wxwidgets
+
+MY_PN="wxHexEditor"
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files"
+HOMEPAGE="http://wxhexeditor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-crypt/mhash
+ dev-libs/udis86
+ x11-libs/wxGTK:2.8[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_pretend() {
+ tc-has-openmp \
+ || die "${PN} uses OpenMP libraries. Please use an OpenMP-capable compiler."
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}