summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-2.5.0.ebuild83
-rw-r--r--app-editors/neovim/Manifest2
-rw-r--r--app-editors/neovim/files/automagic-jemalloc.patch35
-rw-r--r--app-editors/neovim/files/nvimrc105
-rw-r--r--app-editors/neovim/neovim-0.1.1-r1.ebuild (renamed from app-editors/neovim/neovim-0.0.0_pre20151025.ebuild)18
6 files changed, 93 insertions, 151 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index d3145f21d8fb..7a92ae0aae7f 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -3,3 +3,4 @@ DIST nano-2.4.0.tar.gz 1886052 SHA256 5076fb502680503e648cbdcbf2077e39fba193420a
DIST nano-2.4.1.tar.gz 1890805 SHA256 6a0ceb5e1b9b9bea72d5d1f46488ace4782b1f198ea6ba558480a86d994f29d2 SHA512 0e2bc99627682350496853b2dc8d3d4c25303b3723fd1dec2e26f2860b21d0f4c6cb99810517fc4e86312f3bec5481c327afab84dac55f4c388799453e6f5f11 WHIRLPOOL 3c3decdd0c94c33a2cb3854e6b8cda4082a9a98d55d8e1d256ec73febaa0de597d41b1f63c18cb6308fb7174b6ced0995434697f6c05a2efb53e3588f2ca7d8a
DIST nano-2.4.2.tar.gz 1898633 SHA256 c8cd7f18fcf5696d9df3364ee2a840e0ab7b6bdbd22abf850bbdc951db7f65b9 SHA512 487b03b33ac8fac4a774223e038b00463ca03e08093c506b10f4df56795039eff1c23518c1a4f32695cee1bb9bb5eb0a2dd3e1f8a9befcc573e7fca3d69fa9d3 WHIRLPOOL ac5942114a48d428e64db47afb919feef506e18da8b21627ea421e59bf3c235083b17ffaf7a6e510193b6617c0e2ad9d2460f64d5d8bbd6b828547bcd41b5c7c
DIST nano-2.4.3.tar.gz 1878096 SHA256 32d627072b6026678e4f4095c047adec92ac7ec542dd6d91cf27f49b601768f2 SHA512 53c9f93b0f001a3d6c292a6995d66b6bcca033407b6b69995c62b9e9f721fd5566fbd0e22ece1b2561a47e56ef19c3f1ee196e23edfe832289704e0ebef45de9 WHIRLPOOL cd2e4d7175521835c71f0338a2115d2d9fec4da1d4eb2abbb633cfef907fde69fb12acd5e0db343d1f90945f05d60abb85daa5a045d9b97ef8cd19fb9b226607
+DIST nano-2.5.0.tar.gz 1909625 SHA256 ff323e6fef74caf0a924304841c07ac65ec30db99dc5c1f8272b4c536a5c89ee SHA512 f05f1afa6a79ff6b87359c46fbdaf6161eacdc265ac6be155a0173e3ab5a17023e205d0b9667a942e754556182a9007fe4438f337a830d20b9546aad9d522ba6 WHIRLPOOL 29fbb67ce561da8255dca70d7554d604094a21e89e39ce94fadb67bc3236550ea1ee3f08838616deed8a4e37657df0ef6d320c701cc77a086d8d1ce2dae43d1d
diff --git a/app-editors/nano/nano-2.5.0.ebuild b/app-editors/nano/nano-2.5.0.ebuild
new file mode 100644
index 000000000000..48d87ed39596
--- /dev/null
+++ b/app-editors/nano/nano-2.5.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
+ inherit subversion autotools
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-guide.xml"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ epatch_user
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=()
+ case ${CHOST} in
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ esac
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --htmldir=/trash \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable magic libmagic) \
+ $(use_enable spell speller) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ $(usex ncurses --without-slang $(use_with slang)) \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/trash
+
+ dodoc doc/nanorc.sample
+ dohtml doc/faq.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index cf57844bce5f..ebbad181c973 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,2 +1,2 @@
-DIST neovim-0.0.0_pre20151025.tar.xz 4947384 SHA256 62b3bd93e0395c3f2d1f829a1e4e444ac081de1acc99114f6ceba7d61a7055a3 SHA512 a0390097cc0cfae401779ddd229a6237fa63522caaa6515dfff025b506b83e2597a10711bae0a1a60770d2a244963aa56af58f734885ce73091a19865a420bf0 WHIRLPOOL becfec39f4aa1a22f48991f17dbca003f38dfa6b085ed6043e34ed7e852217dddd3e4fce4d33873b0385e1b46754ae11db21ce47cbecd12822e5073d38a5fda1
DIST neovim-0.1.0.tar.gz 7644722 SHA256 e8659558103b8f5a65aac84007a12e3581b32736321778028017fd07365cfff8 SHA512 b91e5ce5561155ecb3554f56fd4371219612ed3bc35dfeb60a225eb1dbe1473fce5f573eb996bdb01fd9569f764da86493108665c98dc7555fc44f410befb00a WHIRLPOOL 33d7b88588c214ddc670a7b3cffcfd855699e90b15c5e327ac0c17972fddb73bd519b1a8eb609f8454d6c463f18764f17bc1314b6b27448c5ac4607cdbce1551
+DIST neovim-0.1.1.tar.gz 7584560 SHA256 f39bcab23457c66ce0d67dcf8029743703f860413db0070f75d4f0ffad27c6c1 SHA512 7098bef9b81862f009789cff49a063d56d52d2f5c74e2fe68ad65c952c61c07eabeb6be150b369a5a179957f20187de3051caaa30b1e0cb4ec1e9e49b4e77333 WHIRLPOOL 9df0d6d59bdda2def2d8a393eec579f341256aff18c485cbb08c96637c597ee4df73a68a09105e776605194412274df2c82b78f7ca0e0bc1e20d4780fcdfa57f
diff --git a/app-editors/neovim/files/automagic-jemalloc.patch b/app-editors/neovim/files/automagic-jemalloc.patch
deleted file mode 100644
index a08fc07b28c7..000000000000
--- a/app-editors/neovim/files/automagic-jemalloc.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-commit bb3c3cbee65ef42b2b3048afae008c719bc2056a
-Author: Ole Reifschneider <mail@ole-reifschneider.de>
-Date: Sat Oct 24 18:48:01 2015 +0200
-
- Make jemalloc optional
-
- Don't enable it automagically if it exists
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 348e138..53e3873 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -260,12 +260,16 @@ if((CLANG_ASAN_UBSAN OR CLANG_MSAN OR CLANG_TSAN) AND NOT CMAKE_C_COMPILER_ID MA
- message(FATAL_ERROR "Sanitizers are only supported for Clang.")
- endif()
-
--if(CLANG_ASAN_UBSAN OR CLANG_MSAN OR CLANG_TSAN)
-- message(STATUS "Sanitizers have been enabled; don't use jemalloc.")
--else()
-- find_package(JeMalloc)
-- if(JEMALLOC_FOUND)
-- include_directories(SYSTEM ${JEMALLOC_INCLUDE_DIRS})
-+option(ENABLE_JEMALLOC "enable jemalloc" OFF)
-+
-+if (ENABLE_JEMALLOC)
-+ if(CLANG_ASAN_UBSAN OR CLANG_MSAN OR CLANG_TSAN)
-+ message(STATUS "Sanitizers have been enabled; don't use jemalloc.")
-+ else()
-+ find_package(JeMalloc)
-+ if(JEMALLOC_FOUND)
-+ include_directories(SYSTEM ${JEMALLOC_INCLUDE_DIRS})
-+ endif()
- endif()
- endif()
-
diff --git a/app-editors/neovim/files/nvimrc b/app-editors/neovim/files/nvimrc
deleted file mode 100644
index 635fc62a0c27..000000000000
--- a/app-editors/neovim/files/nvimrc
+++ /dev/null
@@ -1,105 +0,0 @@
-" Default Gentoo configuration file for neovim
-" Based on the default vimrc shipped by Gentoo with app-editors/vim-core
-" $Id$
-
-" You can override any of these settings on a global basis via the
-" "/etc/vim/nvimrc.local" file, and on a per-user basis via "~/.nvimrc".
-" You may need to create these.
-
-" Neovim comes with sensible defaults, see:
-" https://github.com/neovim/neovim/issues/2676
-" Most of the general settings from Gentoo's vimrc have been dropped here.
-" We add only some necessary fixes and a few Gentoo specific settings.
-
-" {{{ Locale settings
-" If we have a BOM, always honour that rather than trying to guess.
-if &fileencodings !~? "ucs-bom"
- set fileencodings^=ucs-bom
-endif
-
-" Always check for UTF-8 when trying to determine encodings.
-if &fileencodings !~? "utf-8"
- " If we have to add this, the default encoding is not Unicode.
- let g:added_fenc_utf8 = 1
- set fileencodings+=utf-8
-endif
-" }}}
-
-" {{{ Fix &shell, see bug #101665.
-if "" == &shell
- if executable("/bin/bash")
- set shell=/bin/bash
- elseif executable("/bin/sh")
- set shell=/bin/sh
- endif
-endif
-"}}}
-
-" {{{ Our default /bin/sh is bash, not ksh, so syntax highlighting for .sh
-" files should default to bash. See :help sh-syntax and bug #101819.
-if has("eval")
- let is_bash=1
-endif
-" }}}
-
-" {{{ Autocommands
-if has("autocmd")
-
-augroup gentoo
- au!
-
- " Gentoo-specific settings for ebuilds. These are the federally-mandated
- " required tab settings. See the following for more information:
- " http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml
- " Note that the rules below are very minimal and don't cover everything.
- " Better to emerge app-vim/gentoo-syntax, which provides full syntax,
- " filetype and indent settings for all things Gentoo.
- au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab
-
- " In text files, limit the width of text to 78 characters, but be careful
- " that we don't override the user's setting.
- autocmd BufNewFile,BufRead *.txt
- \ if &tw == 0 && ! exists("g:leave_my_textwidth_alone") |
- \ setlocal textwidth=78 |
- \ endif
-
- " When editing a file, always jump to the last cursor position
- autocmd BufReadPost *
- \ if ! exists("g:leave_my_cursor_position_alone") |
- \ if line("'\"") > 0 && line ("'\"") <= line("$") |
- \ exe "normal g'\"" |
- \ endif |
- \ endif
-
- " When editing a crontab file, set backupcopy to yes rather than auto. See
- " :help crontab and bug #53437.
- autocmd FileType crontab set backupcopy=yes
-
- " If we previously detected that the default encoding is not UTF-8
- " (g:added_fenc_utf8), assume that a file with only ASCII characters (or no
- " characters at all) isn't a Unicode file, but is in the default encoding.
- " Except of course if a byte-order mark is in effect.
- autocmd BufReadPost *
- \ if exists("g:added_fenc_utf8") && &fileencoding == "utf-8" &&
- \ ! &bomb && search('[\x80-\xFF]','nw') == 0 && &modifiable |
- \ set fileencoding= |
- \ endif
-
- " Strip trailing spaces on write
- autocmd BufWritePre *.e{build,class}
- \ if ! exists("g:leave_my_trailing_space_alone") |
- \ :%s/\s\+$//e |
- \ endif
-
-augroup END
-
-endif " has("autocmd")
-" }}}
-
-" {{{ nvimrc.local
-if filereadable("/etc/vim/nvimrc.local")
- source /etc/vim/nvimrc.local
-endif
-" }}}
-
-" vim: set tw=80 sw=2 sts=2 et foldmethod=marker :
diff --git a/app-editors/neovim/neovim-0.0.0_pre20151025.ebuild b/app-editors/neovim/neovim-0.1.1-r1.ebuild
index c084410b7ae6..303098a54a5a 100644
--- a/app-editors/neovim/neovim-0.0.0_pre20151025.ebuild
+++ b/app-editors/neovim/neovim-0.1.1-r1.ebuild
@@ -3,21 +3,21 @@
# $Id$
EAPI=5
-inherit cmake-utils eutils flag-o-matic
+inherit cmake-utils flag-o-matic
DESCRIPTION="Vim-fork focused on extensibility and agility."
-HOMEPAGE="https://github.com/neovim/neovim"
+HOMEPAGE="https://neovim.io"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/neovim/neovim.git"
else
- SRC_URI="https://dev.gentoo.org/~tranquility/distfiles/${P}.tar.xz"
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+nvimpager perl python jemalloc"
+IUSE="+nvimpager perl python +jemalloc"
CDEPEND="dev-lang/luajit:2
>=dev-libs/libtermkey-0.17
@@ -36,10 +36,12 @@ RDEPEND="${CDEPEND}
perl? ( dev-lang/perl )
python? ( dev-python/neovim-python-client )"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
src_prepare() {
# use our system vim dir
sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
- -i src/nvim/os/unix_defs.h || die
+ -i src/nvim/globals.h || die
# add eclass to bash filetypes
sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
@@ -47,9 +49,6 @@ src_prepare() {
# make less.sh macro actually work with neovim
sed -e 's|vim |nvim |g' -i runtime/macros/less.sh || die
- # make sure the jemalloc dependency is not automagic
- epatch "${FILESDIR}"/automagic-jemalloc.patch
-
cmake-utils_src_prepare
}
@@ -58,7 +57,6 @@ src_configure() {
append-cflags "-Wno-error"
local mycmakeargs=(
$(cmake-utils_use_enable jemalloc JEMALLOC)
- -DCMAKE_BUILD_TYPE=RelWithDebInfo
-DLIBUNIBILIUM_USE_STATIC=OFF
-DLIBTERMKEY_USE_STATIC=OFF
-DLIBVTERM_USE_STATIC=OFF
@@ -71,7 +69,7 @@ src_install() {
# install a default configuration file
insinto /etc/vim
- doins "${FILESDIR}"/nvimrc
+ doins "${FILESDIR}"/sysinit.vim
# conditionally install a symlink for nvimpager
if use nvimpager; then