summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-daemon')
-rw-r--r--app-emacs/emacs-daemon/Manifest2
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.20.ebuild54
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild54
-rw-r--r--app-emacs/emacs-daemon/metadata.xml5
4 files changed, 115 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/Manifest b/app-emacs/emacs-daemon/Manifest
new file mode 100644
index 000000000000..2b3fd2b3a005
--- /dev/null
+++ b/app-emacs/emacs-daemon/Manifest
@@ -0,0 +1,2 @@
+DIST emacs-daemon-0.20.tar.xz 5120 SHA256 5c0f0bc9a1fab391657737fc3b6af4088eff1ead2e05987fe50e02f5b6e50eb3 SHA512 ac1bfc543f38dd86aeef544a8d03aa2f2a6cb02ee2042ecb3f339baed98294deac1fc6d3d002e654f3d9f32f00379c4de40efa226ddd07715aee7fe0fcb41e43 WHIRLPOOL 5941c1ea18d238275aab312123eb598f3d3265f279674191a75bec6bfd6efeebadb20dc7e6db6454a9da10ed8e98b2916fad195741b4d5fddbb270528e040d63
+DIST emacs-daemon-0.21.tar.xz 5212 SHA256 e07c24d3a92f77d49cecaffdc9dc20d9268505d4ee4879557d0656e6b3c7acd3 SHA512 7131cbd78bb2f11ce3dc5686a3729b8ec11a673e9011c70d72bc04bd5d36373507c9f446ef100d2d37b569850740bf4fb68e06c9e78f3a3bc2b9cdfef8418062 WHIRLPOOL 5c51f985c460a440e6f2b282ad7d289700f621ee1a90c023b4a6f8f317cfd29297ba20f6a8714f27746ee41f9cbae02f200c8bfd39b26d32b0d1c20a56fba48b
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.20.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.20.ebuild
new file mode 100644
index 000000000000..3b42558a46db
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.20.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon
+ which is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing
+ bug in GTK+ that prevents Emacs from recovering from X disconnects:
+ <http://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that
+ you compile it with the Motif or the Lucid toolkit instead, i.e.
+ with USE="motif -athena -gtk" or USE="athena -gtk -motif".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh
+ elisp-site-file-install "${SITEFILE}"
+ dodoc README ChangeLog
+}
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild
new file mode 100644
index 000000000000..e41541f26420
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="http://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <http://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh
+ elisp-site-file-install "${SITEFILE}"
+ dodoc README ChangeLog
+}
diff --git a/app-emacs/emacs-daemon/metadata.xml b/app-emacs/emacs-daemon/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/emacs-daemon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>