summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/muse')
-rw-r--r--app-emacs/muse/Manifest1
-rw-r--r--app-emacs/muse/files/50muse-gentoo.el2
-rw-r--r--app-emacs/muse/metadata.xml30
-rw-r--r--app-emacs/muse/muse-3.20.ebuild35
4 files changed, 68 insertions, 0 deletions
diff --git a/app-emacs/muse/Manifest b/app-emacs/muse/Manifest
new file mode 100644
index 000000000000..52b66c40b0bd
--- /dev/null
+++ b/app-emacs/muse/Manifest
@@ -0,0 +1 @@
+DIST muse-3.20.tar.gz 411316 SHA256 080990e105050fc963bb1938209cc843f259488ae5c8373c5487f99a8dc383b6 SHA512 23cd0e864586f907418753bc3284afde51b4f8559c5d043c52baa70de70ec4a845d9e8362b93e701308dbbd662e3429035df8ad440916e61d5909498cd55f7be WHIRLPOOL 6840d3666925af91ddcc74e69f29216581f4207db9169fb8e39b38797ac9483711b42f8f12be083c8a818faf04f95dc4617b94d4f0eeb06e60d1efa34b7e1339
diff --git a/app-emacs/muse/files/50muse-gentoo.el b/app-emacs/muse/files/50muse-gentoo.el
new file mode 100644
index 000000000000..63bea6e9b3ed
--- /dev/null
+++ b/app-emacs/muse/files/50muse-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'muse-autoloads)
diff --git a/app-emacs/muse/metadata.xml b/app-emacs/muse/metadata.xml
new file mode 100644
index 000000000000..135da40f247e
--- /dev/null
+++ b/app-emacs/muse/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+Emacs Muse is an authoring and publishing environment for Emacs. It
+simplifies the process of writing documents and publishing them to
+various output formats.
+
+Muse consists of two main parts: an enhanced text-mode for authoring
+documents and navigating within Muse projects, and a set of publishing
+styles for generating different kinds of output.
+
+This idea is not in any way new. Numerous systems exist - even one
+other for Emacs itself (Bhl Mode). What Muse adds to the picture is a
+more modular environment, with a rather simple core, in which "styles"
+are derived from to create new styles. Much of Muse's overall
+functionality is optional. For example, you can use the publisher
+without the major-mode, or the mode without doing any publishing; or
+if you don't load the Texinfo or LaTeX modules, those styles won't be
+available.
+
+The Muse codebase is a departure from emacs-wiki.el version 2.44. The
+code has been restructured and rewritten, especially its publishing
+functions. The focus in this revision is on the authoring and
+publishing aspects, and the "wikiness" has been removed as a default
+behavior (available as the optional module muse-wiki.el). CamelCase
+words are no longer special by default.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/muse/muse-3.20.ebuild b/app-emacs/muse/muse-3.20.ebuild
new file mode 100644
index 000000000000..f403efd922af
--- /dev/null
+++ b/app-emacs/muse/muse-3.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Muse-mode is similar to EmacsWikiMode, but more focused on publishing to various formats"
+HOMEPAGE="http://mwolson.org/projects/EmacsMuse.html"
+SRC_URI="http://download.gna.org/muse-el/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2 GPL-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="test"
+RESTRICT="test" #426546
+
+DEPEND="test? ( app-emacs/htmlize )"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el lisp/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo texi/muse.info
+ dodoc AUTHORS NEWS README ChangeLog*
+ insinto /usr/share/doc/${PF}
+ doins -r contrib etc examples experimental scripts
+}