summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/nxml-libvirt-schemas')
-rw-r--r--app-emacs/nxml-libvirt-schemas/Manifest2
-rw-r--r--app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el5
-rw-r--r--app-emacs/nxml-libvirt-schemas/files/Makefile-trang6
-rw-r--r--app-emacs/nxml-libvirt-schemas/files/schemas.xml12
-rw-r--r--app-emacs/nxml-libvirt-schemas/metadata.xml9
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild55
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild55
7 files changed, 144 insertions, 0 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/Manifest b/app-emacs/nxml-libvirt-schemas/Manifest
new file mode 100644
index 000000000000..db2166feebfd
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/Manifest
@@ -0,0 +1,2 @@
+DIST libvirt-0.9.7.tar.gz 17853636 SHA256 29ff05bfe5177d6680c02c279ed2573dcfae993f2824bffa192a3a2cdd05af23 SHA512 ac082f3872b37fc7aad891ba3f2a9614bdc85123b3d626fc7a2e43327a7ec346a0ec154c25161592a4337e3f694d9b27d031544190dec7d6086343f15fe9ba2d WHIRLPOOL 1704503c979b20a7bb31da4007724b7fd537d7f4f95dc7c0d8929d24f5f7c297c4d1f4d4d2a541265fa9c87b2bfba1d27a8b61c9ab29b092916dedb7a5a52a23
+DIST libvirt-1.2.1.tar.gz 27228694 SHA256 bc29b5751bf36753c17e2fdbb75e70c7b07df3d9527586d3426e90f5f4abb898 SHA512 6184840623156ca01ee7f59078ebf031bc84c25b37bb110372c7bcf230a79b74e267475f989fb73db5e3c096dcc74f03cb30adfc5de022f756ed2cd6ab05bfd0 WHIRLPOOL 75c2a37b1101950474aad8931d999564ff575512d38c9e8d2cf989cef3ad7057853046b738b20bd77be80c1e6677319aea7227797ae95ce91512dc36bd05a142
diff --git a/app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el b/app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el
new file mode 100644
index 000000000000..c574746e6576
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el
@@ -0,0 +1,5 @@
+;; This must be executed after rng-schema-locating-files
+;; is set in rng-loc (which is part of nxml-mode).
+(eval-after-load "rng-loc"
+ '(add-to-list 'rng-schema-locating-files
+ "@SITEETC@/schemas.xml"))
diff --git a/app-emacs/nxml-libvirt-schemas/files/Makefile-trang b/app-emacs/nxml-libvirt-schemas/files/Makefile-trang
new file mode 100644
index 000000000000..699cf676ff45
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/files/Makefile-trang
@@ -0,0 +1,6 @@
+# -*- makefile -*-
+
+all: $(patsubst %.rng,%.rnc,$(wildcard *.rng))
+
+%.rnc: %.rng
+ trang -I rng -O rnc $< $@
diff --git a/app-emacs/nxml-libvirt-schemas/files/schemas.xml b/app-emacs/nxml-libvirt-schemas/files/schemas.xml
new file mode 100644
index 000000000000..47936ab24a16
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/files/schemas.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="utf-8"?>
+<locatingRules xmlns="http://thaiopensource.com/ns/locating-rules/1.0">
+ <!-- As far as I can see there is no way to apply more than one to
+ search for a file, so we're going to use some very generic
+ locating rules… yes it's bad, but upstream libvirt doesn't
+ intend to change that anytime soon.
+ -->
+
+ <documentElement localName="domain" uri="domain.rnc" />
+ <documentElement localName="pool" uri="storagepool.rnc" />
+ <documentElement localName="network" uri="network.rnc" />
+</locatingRules>
diff --git a/app-emacs/nxml-libvirt-schemas/metadata.xml b/app-emacs/nxml-libvirt-schemas/metadata.xml
new file mode 100644
index 000000000000..a178e33b29d2
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>virtualization</herd>
+<maintainer>
+ <email>flameeyes@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild
new file mode 100644
index 000000000000..2932487db480
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+#BACKPORTS=
+
+inherit elisp eutils
+
+MY_P="libvirt-${PV/_rc/-rc}"
+
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="http://www.libvirt.org/"
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${MY_P}-backports-${BACKPORTS}.tar.bz2}"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+RDEPEND=""
+
+SITEFILE="60${PN}-gentoo.el"
+S="${WORKDIR}/${MY_P%-rc*}"
+
+src_prepare() {
+ if [[ -d "${WORKDIR}/patches" ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ epatch
+ fi
+}
+
+src_compile() {
+ emake -C docs/schemas -f "${FILESDIR}/Makefile-trang"
+}
+
+src_test() {
+ # No we don't need tests here... trang will take care of checking
+ # the well-formedness of the schema files for us
+ :
+}
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}/schemas.xml" docs/schemas/*.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild
new file mode 100644
index 000000000000..5f1a1d664864
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#BACKPORTS=
+
+inherit elisp eutils
+
+MY_P="libvirt-${PV/_rc/-rc}"
+
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="http://www.libvirt.org/"
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${MY_P}-backports-${BACKPORTS}.tar.bz2}"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+RDEPEND=""
+
+SITEFILE="60${PN}-gentoo.el"
+S="${WORKDIR}/${MY_P%-rc*}"
+
+src_prepare() {
+ if [[ -d "${WORKDIR}/patches" ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ epatch
+ fi
+}
+
+src_compile() {
+ emake -C docs/schemas -f "${FILESDIR}/Makefile-trang"
+}
+
+src_test() {
+ # No we don't need tests here... trang will take care of checking
+ # the well-formedness of the schema files for us
+ :
+}
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}/schemas.xml" docs/schemas/*.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}