summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/python-mode/python-mode-6.1.1.ebuild')
-rw-r--r--app-emacs/python-mode/python-mode-6.1.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/python-mode/python-mode-6.1.1.ebuild b/app-emacs/python-mode/python-mode-6.1.1.ebuild
new file mode 100644
index 000000000000..6ff5dafb5d7e
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+DOC_CONTENTS="Note that doctest and pymacs are in their own packages,
+ app-emacs/doctest-mode and app-emacs/pymacs, respectively."