summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/sml-mode/sml-mode-6.4.ebuild')
-rw-r--r--app-emacs/sml-mode/sml-mode-6.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/sml-mode-6.4.ebuild b/app-emacs/sml-mode/sml-mode-6.4.ebuild
new file mode 100644
index 000000000000..fa0bec00396e
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from http://elpa.gnu.org/packages/${P}.el
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}