summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/uxntal-mode')
-rw-r--r--app-emacs/uxntal-mode/Manifest1
-rw-r--r--app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el4
-rw-r--r--app-emacs/uxntal-mode/metadata.xml14
-rw-r--r--app-emacs/uxntal-mode/uxntal-mode-0.3.ebuild19
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/uxntal-mode/Manifest b/app-emacs/uxntal-mode/Manifest
new file mode 100644
index 000000000000..4507db7f027f
--- /dev/null
+++ b/app-emacs/uxntal-mode/Manifest
@@ -0,0 +1 @@
+DIST uxntal-mode-0.3.tar.gz 9906 BLAKE2B fc0126c99ebaae2f8f95b7364dc56341de012d7b010a13ac362dda2bc81b110f60bdb8c5e7d1f764b0368538e4657aa989e75797566499cd58e4b3f85ae12d66 SHA512 d161b96d8c80cd7e3761cf05ffb7f4711755c5ec2282fdb9ee0a2e77dc78f7ed059482641908c645371794c7d258e5f6fae0971d281e56e2e80397026b4fa441
diff --git a/app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el b/app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el
new file mode 100644
index 000000000000..916ad70e1619
--- /dev/null
+++ b/app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'uxntal-mode "uxntal-mode"
+ "Major mode for editing Uxntal files." t)
+(add-to-list 'auto-mode-alist '("\\.tal\\'" . uxntal-mode))
diff --git a/app-emacs/uxntal-mode/metadata.xml b/app-emacs/uxntal-mode/metadata.xml
new file mode 100644
index 000000000000..d8c98f52eae3
--- /dev/null
+++ b/app-emacs/uxntal-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/non/uxntal-mode/issues/</bugs-to>
+ <remote-id type="github">non/uxntal-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/uxntal-mode/uxntal-mode-0.3.ebuild b/app-emacs/uxntal-mode/uxntal-mode-0.3.ebuild
new file mode 100644
index 000000000000..bd0c0b36f9fd
--- /dev/null
+++ b/app-emacs/uxntal-mode/uxntal-mode-0.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for the uxntal assembly language"
+HOMEPAGE="https://github.com/non/uxntal-mode/"
+SRC_URI="https://github.com/non/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"