summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild12
-rw-r--r--app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild12
-rw-r--r--app-emacs/twittering-mode/twittering-mode-9999.ebuild12
3 files changed, 15 insertions, 21 deletions
diff --git a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
index b858dc10fc4e..1e802fc217fc 100644
--- a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp elisp-common eutils
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
- inherit git-2
- SRC_URI=""
- KEYWORDS=""
+ inherit git-r3
IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
@@ -29,7 +27,7 @@ RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +35,6 @@ src_test() {
}
src_install() {
- [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}
diff --git a/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
index b858dc10fc4e..1e802fc217fc 100644
--- a/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp elisp-common eutils
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
- inherit git-2
- SRC_URI=""
- KEYWORDS=""
+ inherit git-r3
IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
@@ -29,7 +27,7 @@ RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +35,6 @@ src_test() {
}
src_install() {
- [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}
diff --git a/app-emacs/twittering-mode/twittering-mode-9999.ebuild b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
index b858dc10fc4e..1e802fc217fc 100644
--- a/app-emacs/twittering-mode/twittering-mode-9999.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp elisp-common eutils
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
- inherit git-2
- SRC_URI=""
- KEYWORDS=""
+ inherit git-r3
IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
@@ -29,7 +27,7 @@ RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +35,6 @@ src_test() {
}
src_install() {
- [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}