summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch12
-rw-r--r--app-emacs/treepy/treepy-0.1.1-r1.ebuild20
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch b/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch
new file mode 100644
index 000000000000..0c7bfbad1b85
--- /dev/null
+++ b/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch
@@ -0,0 +1,12 @@
+Fix byte-compilation with Emacs 27.
+
+--- treepy.el-0.1.1-orig/treepy.el
++++ treepy.el-0.1.1/treepy.el
+@@ -40,6 +40,7 @@
+ ;;
+ ;;; Code:
+
++(require 'cl-lib)
+ (require 'map)
+
+ ;;; Walk (recursive tree traversal)
diff --git a/app-emacs/treepy/treepy-0.1.1-r1.ebuild b/app-emacs/treepy/treepy-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..ed95978e0603
--- /dev/null
+++ b/app-emacs/treepy/treepy-0.1.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Generic tree traversing tools for Emacs Lisp"
+HOMEPAGE="https://github.com/volrath/treepy.el"
+SRC_URI="https://github.com/volrath/treepy.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=("${FILESDIR}"/${P}-cl-lib.patch)
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"