summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-proxy')
-rw-r--r--app-emulation/docker-proxy/Manifest1
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/Manifest b/app-emulation/docker-proxy/Manifest
index be7eb609435f..ada44a642db1 100644
--- a/app-emulation/docker-proxy/Manifest
+++ b/app-emulation/docker-proxy/Manifest
@@ -1,2 +1,3 @@
DIST docker-proxy-0.8.0_p20170917.tar.gz 2177045 BLAKE2B 0fed1328e8216ab83b23e8e1fe1793da6e874eced7ad18d101b0b7757f1de4fa7d321fb78620a349a4ed492abb4d85c3ecbf49311698b6af156a6255dec5740e SHA512 673ea638fa5c560d8238d7c1d88f114430f9d8efe701804bfe30044d0c059a688cbf6b62922be50834e16ee055ef6cf015f6232f76f0d942768f9e84e95496cd
DIST docker-proxy-0.8.0_p20180314.tar.gz 2692292 BLAKE2B 6d09750277691313f16ff48c14e2b8f706180dad0805b4874bfc7ed228e090ad1e5a1bdfe1555970424dfde78a31de3373c76c7417c6e5cabedf4da551e49934 SHA512 c33005f0281260a3dcc9dd567680068afbdb9ea6036b2847c9cd3d77e72d32e6b7d359178acbd4a2db7cc15cc53d99079a1b544bc32912dbf19f2babc670a2bd
+DIST docker-proxy-0.8.0_p20180411.tar.gz 2695069 BLAKE2B 5205d5700ad116bb457dc7a57f2624f9efa46f1dbf3f5fe9215077655cddba8e1e1301bc555fb43a22cba4d74423123953a67994bf8974b114350e64be601299 SHA512 300e197313017536f91768ba675f2ab773eb1914f8e5908f4ff5b6fc8c4f0fa5ba1653cd9f8ca26e7c466f1623716aa45a2746f862e47ca9fe9136010085f600
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild
new file mode 100644
index 000000000000..2eba51cd06ba
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="c15b372ef22125880d378167dde44f4b134e1a77"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RDEPEND="!<app-emulation/docker-1.13.0_rc1"
+
+RESTRICT="test" # needs dockerd
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc ROADMAP.md README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}