summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-php/eselect-php-9999.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/app-eselect/eselect-php/eselect-php-9999.ebuild b/app-eselect/eselect-php/eselect-php-9999.ebuild
index bbb40ca5261d..f32c4a68a2f6 100644
--- a/app-eselect/eselect-php/eselect-php-9999.ebuild
+++ b/app-eselect/eselect-php/eselect-php-9999.ebuild
@@ -28,12 +28,12 @@ src_configure(){
# We expect localstatedir to be "var"ish, not "var/lib"ish, because
# that's what PHP upstream expects. See for example the FPM
# configuration where they put logs in @localstatedir@/log.
- econf --localstatedir="${EPREFIX}"/var $(use_enable apache2)
+ econf --localstatedir="${EPREFIX}"/var $(use_enable apache2) $(use_enable fpm)
}
src_install() {
default
- [[ -f "${D}/etc/init.d/php-fpm.example.init" ]] && rm "${D}/etc/init.d/php-fpm.example.init" || die
+
# This can be removed after a while...
if use apache2 ; then
insinto /etc/apache2/modules.d
@@ -41,8 +41,6 @@ src_install() {
fi
if use fpm ; then
- newinitd "doc/php-fpm.example.init" "php-fpm"
- newconfd "doc/php-fpm.example.conf" "php-fpm"
systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
exeinto /usr/libexec
newexe "${FILESDIR}/php-fpm-launcher-r1" php-fpm-launcher