summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/pushgateway/pushgateway-1.0.0.ebuild')
-rw-r--r--app-metrics/pushgateway/pushgateway-1.0.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-metrics/pushgateway/pushgateway-1.0.0.ebuild b/app-metrics/pushgateway/pushgateway-1.0.0.ebuild
deleted file mode 100644
index 2cc3feddfe7c..000000000000
--- a/app-metrics/pushgateway/pushgateway-1.0.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module user systemd
-
-EGIT_COMMIT="v${PV/_rc/-rc.}"
-GIT_COMMIT="cc61f46"
-
-DESCRIPTION="Prometheus push acceptor for ephemeral and batch jobs"
-HOMEPAGE="https://github.com/prometheus/pushgateway"
-SRC_URI="https://github.com/prometheus/pushgateway/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-BDEPEND=">=dev-util/promu-0.3.0"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- default
- sed -i -e "s/{{.Revision}}/${GIT_COMMIT}/" .promu.yml || die
-}
-
-src_compile() {
- mkdir -p bin || die
- promu build -v --prefix bin || die
-}
-
-src_install() {
- dobin bin/*
- dodoc {README,CHANGELOG,CONTRIBUTING}.md
- keepdir /var/lib/${PN} /var/log/${PN}
- fowners ${PN}:${PN} /var/lib/${PN} /var/log/${PN}
- newinitd "${FILESDIR}"/${PN}-1.initd ${PN}
- newconfd "${FILESDIR}"/${PN}-1.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}-1.service"
-}