summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cherrytree')
-rw-r--r--app-text/cherrytree/cherrytree-0.37.0-r1.ebuild12
-rw-r--r--app-text/cherrytree/cherrytree-0.38.9-r1.ebuild (renamed from app-text/cherrytree/cherrytree-0.38.9.ebuild)14
2 files changed, 15 insertions, 11 deletions
diff --git a/app-text/cherrytree/cherrytree-0.37.0-r1.ebuild b/app-text/cherrytree/cherrytree-0.37.0-r1.ebuild
index b7c0b37e37f2..1e0aa58e0412 100644
--- a/app-text/cherrytree/cherrytree-0.37.0-r1.ebuild
+++ b/app-text/cherrytree/cherrytree-0.37.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,10 +19,12 @@ SLOT="0"
IUSE="nls"
RDEPEND="${PYTHON_DEPS}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pyenchant[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- dev-python/pygtksourceview:2[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${RDEPEND}"
BDEPEND="nls? ( sys-devel/gettext )"
diff --git a/app-text/cherrytree/cherrytree-0.38.9.ebuild b/app-text/cherrytree/cherrytree-0.38.9-r1.ebuild
index 80af20d9208c..3451ffc2b7e6 100644
--- a/app-text/cherrytree/cherrytree-0.38.9.ebuild
+++ b/app-text/cherrytree/cherrytree-0.38.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,11 +19,13 @@ SLOT="0"
IUSE="nls"
RDEPEND="${PYTHON_DEPS}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pyenchant[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${RDEPEND}"
BDEPEND="nls? ( sys-devel/gettext )"